Adding a hyperlink to form label

SOLVE
Occasional Contributor

Hey fellow Hubspotters

 

I'd like to add a link to our privacy policy next to the 'Email' label in our forms, as Hubspot has done on their own forms, but I can't figure out how.

Elsewhere in the community users have suggested changing the styling of the forms - can someone point me in the direction of where I might do that?

Or if there's a simpler way, I'd love to know Smiley Happy

/Rikke

Hubspots formular.PNG

1 Accepted solution

Accepted Solutions
Advisor

I'm not a design expert, but I added a link to our privacy policy by simply adding it to the Email label of any forms I've created in the form editor. It does take on the .css style that we have set up for links on our pages, which you can find if you right-click inspect on any link:

 

Capture.PNG

 

 

Capture.PNGResult:Capture.PNG

Did my post help answer your query? Help the Community by marking it as a solution.
7 Replies 7
Advisor

I'm not a design expert, but I added a link to our privacy policy by simply adding it to the Email label of any forms I've created in the form editor. It does take on the .css style that we have set up for links on our pages, which you can find if you right-click inspect on any link:

 

Capture.PNG

 

 

Capture.PNGResult:Capture.PNG

Did my post help answer your query? Help the Community by marking it as a solution.
Highlighted
Occasional Contributor

How wonderfully simple, @shearn !

 

Thanks a million for sharing that tip Smiley Happy

Reply
0 Upvotes
Occasional Contributor

Hi again, @shearn

 

When you set this up, did you experience any problems with the link?

 

I can't get the link to work properly - it delivers a 404.

 

In my case, I write the label text with the link as so:

 

Email (<a href=”https://www.timelog.com/en/about/cookie-policy/” target=”_blank”>Privacy Policy</a>)

 

But somehow Hubspot changes it to:

http://info.timelog.com/%E2%80%9Dhttps://www.timelog.com/en/about/cookie-policy/%E2%80%9D

 

Would love to hear, if this happened to you too - and of course if there's a way to fix it Smiley Happy

Thx,

Rikke

Reply
0 Upvotes
Advisor

Hi @RikkeMarieS,

 

That hasn't happened to me...Not sure why it would add the info. part to your link. I even created a test form and added your privacy policy URL to my label and it worked fine.

 

I've tried to retrace my steps and see if I added anything additional to get it to show, but I can't see anything out of the ordinary.

 

 

I asked about this on the Design Forum here when I wanted it added: https://community.hubspot.com/t5/Content-Design-Questions/Adding-Privacy-Policy-T-amp-C-s-link-to-Hu...

 

I didn't use the solution, but maybe it could be an option?

 

Maybe you could ask on that forum as well? Folks over there have a little more knowledge than me! Smiley Happy

Did my post help answer your query? Help the Community by marking it as a solution.
Reply
0 Upvotes
Occasional Contributor

Hi @shearn

 

Thanks a lot for testing this at your end - it's nice to know, that the problem only happens in my portal (though weird) Smiley Happy

 

And thanks for the link - will definitely look into that!

 

/Rikke

Reply
0 Upvotes
Visitor

Hi,

 

This code should work , write this in a Rich text :

 

<a href="YOUR URL"  target=”_blank”> <span style="display: block;" > TEXT TO SHOW </span> </a>

 

 

Just replace YOUR URL with your link.

 

Reply
0 Upvotes
New Contributor

Hi @RikkeMarieS,

 

did you manage to fix the problem with the link? Unfortunately, this error also occurs with me.

 

Thx,

Alex

Reply
0 Upvotes