Knowledge Base Tool

SWeller
Participant

Knowledge Base Articles (some) not appearing in search engine results - why?

Our knowledge base is public (and we do want the articles to be shown in the SERPs).

 

However, some articles are not appearing anymore for some reason (yet some show with no problems). Most importantly this page is not showing up in Google at all. 

 

I've checked this out on Google Search Console, which confirms it's not in the index, but not because of an error. See below. I've requested indexing, but I can't do this for every page. We haven't edited any scripts, or added no index tags etc. 

 

Does anyone have any insight on this?

 

KB.png

7 Replies 7
TesaReichts
Participant

Knowledge Base Articles (some) not appearing in search engine results - why?

I have the same issue with some blog posts. @SWeller did you find a solution jet?

0 Upvotes
SWeller
Participant

Knowledge Base Articles (some) not appearing in search engine results - why?

Unfortunately, I don't have a particularly helpful answer for you as it seems to be sorted now. All I did was request indexing in Google Search Console and over time the missing articles have reappeared. 

0 Upvotes
TesaReichts
Participant

Knowledge Base Articles (some) not appearing in search engine results - why?

It's super strange. Sadly, indexing manually doesn't help us. We then get this message:

 

Discovered - currently not indexed: The page was found by Google, but not crawled yet. Typically, Google wanted to crawl the URL but this was expected to overload the site; therefore Google rescheduled the crawl. This is why the last crawl date is empty on the report.

0 Upvotes
TesaReichts
Participant

Knowledge Base Articles (some) not appearing in search engine results - why?

Looks like we are not the only ones with this issue https://support.google.com/webmasters/thread/138283551/hubspot-blog-pages-not-indexed?hl=en

@webdewand @Annie_Birai any ideas what might be the problem?

0 Upvotes
webdew
Guide | Diamond Partner
Guide | Diamond Partner

Knowledge Base Articles (some) not appearing in search engine results - why?

Hi @SWeller ,

As @Annie_Birai Suggested, do the setting in your HubSpot settings. A small video for you to demo the same

Hope this helps!

If we were able to answer your query, kindly help the community by marking it as a solution.
Thanks and Regards.

0 Upvotes
SWeller
Participant

Knowledge Base Articles (some) not appearing in search engine results - why?

The crawler access is turned on in the settings so I don't think that's the issue. 

0 Upvotes
Annie_Birai
Contributor | Platinum Partner
Contributor | Platinum Partner

Knowledge Base Articles (some) not appearing in search engine results - why?

Have you checked your setting Knowlege Base settings to ensure non-index did not get toggled on? HubSpot Settings > Website > Knowledge Base and toggle off the switch if it is on.

 

0 Upvotes