Disable automatic contact creation for Conversations

jehiguese

HubSpot auto creates a contact for anyone that emails in - or is cc'd into a reply in conversations. For some customers who manage through support, this will mean a large number of contacts can enter the database. The only way to prevent this at the moment is by setting filtering rules, as all filtered emails do not create contacts. There is a use case from a customer in this post..

 

This is a request to build a "Create contact" rule giving us the option to disable automtically creating contacts for people we communicate with in Conversations.

 

158 Replies
dave-kimble
Participant

It's why we stopped using HubSpot, and it's unfortunate because overall we preferred HubSpot.

NFitz
Member

+1 

 

This would be great to address.

ASaeed
Member

Any Updates on this yet? I have been googling left and right to try to stop this creating contact thing.

iamathlete
Contributor | Platinum Partner

not yet.  what i've done in the meantime is 
1. created a saved filter in Contacts for contacts that were created via Conversations and aren't a "Customer" or owned by a sales person
2. created a saved filter in Companies with the same
3. Every 3 days I go into the filters and delete everything.  

 

Sure hope I'm not deleting leads.

 

Rpetersen
Member

This would be helpful even for those not using conversations. My sales team has been complaining since we started using HubSpot about how it automatically creates a contact when someone emails them first. They know to uncheck "log to crm" when they email first.. This results in random industry people etc being added to our database that constantly needs to be cleaned now. 

 

Any update on this change would be helpful!

 

 

LAsiel
Member

Did this feature get developed? Currently drudging through all the no-reply contacts that have been auto-added to Hubspot and it is quite a pain! Would love to have better control over what contacts are added. 

DataHawks
Member
Nothing developed that I’ve heard off! It’s so annoying, can’t believe it hasn’t been picked up and fixed

Sent from my iPhone
MatS1
Member

please fix this. it's much needed. thanks!

Kris1
Member

Hi @cdewey22 !

 

It's been a year since your last post. Could you please let us know when will this be solved?

 

This is obviously a popular request and the "feature" you currently have causes a lot of confusion and extra work for Hubspot users. Please get it fixed!

Repool
Member

I actually can't believe this is not a feature.  This basically means the Hubspot email tracking functionality is completely unusable by anyone who deals with sensitive emails; executives, VPs, C-Suite.   Disappointing as I wanted to use Hubspot but i'll stick to SFDC I guess.

TConnolly
Member

Surprised there is no way to block these types of "auto create"

EBitting
Member

*Kick* This is a much needed setting. We spend a lot of time manually deleting contacts created via cc's in emails.

Jonno_Price
Top Contributor | Platinum Partner

I have a number of clients where I've setup and configured Conversations Inbox for them who after a while ask me to disconnect it as a result of the clutter it causes. 

 

Another option would be one click delete of both the contact and company created directly in the Conversation Inbox.

 

Currently you can "Block and delete contact" but it leaves the random company in the CRM if automated company creation is turned on. Would be nice to have "Delete contact and company" as an additional option. 

 

This doesn't solve the issue raised by a few people commenting in this thread regarding contacts created by email CC (which is actually a different topic) but it would make monitoring and managing the Conversation Inbox easier. 

 

Thanks

AliceH
Member

@cdewey22 any update on this?

 

We're new to HubSpot and just come across the same issue, with no way of stopping it from artifically inflating our number of contacts. Seems a bit unfair when we're charged on our number of contacts.

AndreasTrunz
Participant

As our project management uses Conversations to centralize all their communication with our customers and users, and since these are not identical, HubSpot automatically creates contacts that we do not want in our CRM. 

Sometimes a user of our SaaS solution is indeed a potential stakeholder and relevant for Marketing and Sales. But most other contacts that we send emails to (for example with login data and help), will not be contacted again.

 

So, ideally, HubSpot should ask us if a new contact should be created when an unknown email address is inserted in an email within Conversations.

If I chose to add a contact, then I should be asked to fill out the same data fields as I have to do when adding a new contact manually.

JCreacy
Member
This is a great point. HubSpot please fix this

Get Outlook for iOS
CONFIDENTIAL: This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify That Menu App, LLC. This message contains confidential information and is intended only for the individual named. If you are not the named addressee you should not disseminate, distribute or copy this e-mail. Please notify the sender immediately by e-mail if you have received this e-mail by mistake and delete this e-mail from your system. If you are not the intended recipient you are notified that disclosing, copying, distributing or taking any action in reliance on the contents of this information is strictly prohibited. For additional information or to report a breach of confidentiality, please email legal@thatmenuapp.com.
ASaeed
Member

Lol guys?

I think this problem was fixed a long time ago ... check this screenshot out ... lol I would be looking at this thread and think "Are these guys serious?" If I was Hubspot lol .... but in our defense, the platform isnt too intuitive? lol jk 😛Screen Shot 2021-07-23 at 9.51.12 AM.png

Shelina
Member

Has this been sorted out as I am getting contacts being added from my phone book etc. What do i remove from the settings to get this to stop? thanks 

ASaeed
Member

Settings > General > Email > turn off the email thing

Shelina
Member

Amazing thank you 🙂