Add "noresize" option to CTAs

Migrated from legacy feedback forum with 20 votes.

 

Wasn't sure where to put this one since CTAs are available across the platform. However, we often create visual CTAs that contain text. Even though we save them at 144dpi, the system automatically compresses them, which makes the image blurry - especially the fonts. When these CTAs are used on the site, they really stand out and look low quality.

HubSpot updates
11 Replies
T_G
New Contributor

 We are having extraordinary issues with image compression - so much so that we are starting to send out emailers from an outside platform.  No matter what we do, our clients logos and even button CTAs look smudgy, with hours spent on the phone with Hubspot support.  They're always as helpful as they can be, but the platform doesn't appear to support retina displays or newer iPhone displays. We cannot understand why Hubspot is compressing the image file that is created from a CTA, as the image is already small.   

ljbren
New Contributor

Having this issue as well, and am really surprised that HubSpot hasn't addressed it yet. I have not run into this issue on far less expensive platforms.

mitchellkp
Top Contributor
PeterSherlock
New Contributor

Yo! 

 

I use rich text elements and then upload my images including cta's there. Click to open up the source code on the rich text element, add in "?noresize" to the end of your src=".png?noresize" then set your style there - style="max-width:xxx" .. etc.

 

You can do this for header images, as well as any image in the body of your email. This will not degrade the quality, and show a full crisy image. Let me know if this helps - it is a some waht tedious process but I think having crisp image quality is very important to presenting a legitimate brand.

ljbren
New Contributor

Hey Peter -- can you share a picture of your code for this? I think it's what I've already been doing (which hasn't worked) but I could be missing something,. Would love to see how you've solved it!

 

Thanks!

JorgenDavidson
Occasional Contributor

This is a SERIOUS platform problem. HubSpot doesn't have many problems that I feel really affect my ability to do my job but this was a really challenging one. I also use the rich text module with a ?noresize tag at the end of the image url in the <img src> tag. That works ok but there's no way that should be a long term solution. 

 

PLEASE FIX THIS!

BryZ
Visitor

Guys I am pretty confident that the ?noresize DOES NOT WORK. We tried it and it makes images look ok in the builder, but once you send the email it looks bad again. Am I right??

PeterSherlock
New Contributor

<img src="https://cdn2.hubspot.net/hubfs/4014496/quote_instant_sales_2x.png?noresize" width="50%" height="auto"/>

 

Here is an example of my code.

 

I typically like to resize images to 2x then use https://imageoptim.com/mac to reduce the file size, then half the size in my email so I am always delivering the highest reslution images, while maintaining quick load times.

 

Best,

 

Peter

 

@BryZ Let me know if you have any questions.

heidiperry
New Contributor

We have tried the ?noresize option but it doesn't seem to be an option for CTAs that you'd embed inside emails. Would welcome any thoughts on CTA workarounds to get images to look non-grainy. thanks!

PeterSherlock
New Contributor

1. Use a rich text element in your template.

2. Add an image to the rich text element like this one: - suggest using a 2x image size, and reducing size. 2x button.png

3. Add any link to your image. Don't worry Hubspot will automatically track this email when you set the campaign type.

4. Open the HTML editor for your rich text element, and add in the ?noresize, after the URL.

 

This is my work around for the CTA issue. I dont use the actual CTA functionality in hubspot.