Update means that we cannot automatically track email activity to new company records

steph_feltham
Participant

A new Hubspot update means that when we send an email to a NEW contact - it only associates the email with the contact record - not the company record.

 

Apparently we now have to go in and manually check a box for EVERY new email we send to say that we want to associate it with the company record.

 

The reason we need this is that we have weekly team reviews of the number of emails sent and meetings scheduled for specific industries - as we can't filter contacts by industry (and often have numerous contacts at each company)  it's quicker to go through them in the company view - we look at the last contacted column and the next activity date column to quickly see if a company has been emailed and if a meeting has been scheduled.

 

This update has now made this impossible and the amount of manual updating required is far too much.

 

Is there any workaround to this - or option to turn the new feature off?

 

Thanks

 

 

0 Upvotes
5 Replies 5
sharonlicari
Community Manager

Hi @steph_feltham

 

Welcome to the Community!

 

Could you please advise where did you see these changes? I've done a test on my own portal and I'm not able to reproduce what you are describing. 

 

Thank you

Sharon


¿Sabías que la Comunidad está disponible en Español?
¡Participa hoy en conversaciones en el idioma de tu preferencia,cambiando el idioma en tus configuraciones!

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
steph_feltham
Participant

In the contact record, select the email sent, select 'associated records' - Company is now always unchecked by default for the first email. So for every email we send to a new contact, we have to go in and manually associate it with the company record. 

0 Upvotes
steph_feltham
Participant

@sharonlicari - Is there any news on this? It's causing us lots of issues. Thanks

0 Upvotes
steph_feltham
Participant

@sharonlicari - Can someone please update me on this...?

0 Upvotes
sharonlicari
Community Manager

Hi @steph_feltham 

 

I've been testing again and I'm not able to reproduce this! I can see you have a paid subscription and you had opened a ticket with our technical support team. I'd recommend contacting the team again in order to review and investigate this for you, as I don't have access to different tools. 

 

Thank you

Sharon 


¿Sabías que la Comunidad está disponible en Español?
¡Participa hoy en conversaciones en el idioma de tu preferencia,cambiando el idioma en tus configuraciones!

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !