RESOLVED: Feb 14, 2019: Gmail Extension Self-Open Notifications

SOLVE
Highlighted
HubSpot Employee

We are currently seeing the Gmail Extension generate self-open notifications when you view a sent email that was tracked from your "Sent" folder. We believe the root cause of the issue is a new update to Chrome 72. 

 

The current solution is:

1. Navigate to chrome://flags/#network-service
2. Select the dropdown next to the "Enable network service" option, and click "Disabled"
3. Click the "Relaunch Now" button at the bottom of the page.

 

Once the browser relaunches, self open blocking should continue to work as expected.

 

We are working on a more permanent solution now and will update here and on https://status.hubspot.com

 

Please let us know if you see any other issues! 

 

clique aqui para visualizar em Português (click here to view in Portuguese)

 

This issue has been resolved. If you encounter any functionality issues with Gmail emails, please post them in the Gmail Sales Extension board.

2 Accepted solutions

Accepted Solutions
HubSpot Employee

We have been in communicaton with the Google team and this will be resolved in Chrome 73. Please use the documented solution here until then. 

 

Please note: this is specific to the Gmail extension. If you are seeing this issue in an email client without an extension such as a mobile device or Apple mail, please refer to this knowledge doc to block HubSpot Sales email open and click tracking from your own IP.

HubSpot Employee

If you are still seeing this persist in the Gmail Extesnsions, please update to Chrome to 72.0.3626.117 (or later) to resolve this issue. 

 

This update can be triggered by:

1) Go to: chrome://settings/help on Chrome

2) Waiting for update to download

3) Relaunching Chrome 

 

Thank you for everyone's comments and patience as we are working through this. The previous workaround should have no impact on your regular workflow and Chrome but if you have updated Chrome to 72.0.3626.117 or later, you can also undo the workaround. 

 

Let me know if there is more information I can provide! 

25 Replies
New Contributor

Thanks I've noticed this was an issue before now, too. Have followed instructions and disabled network services for now. Will let you know if it works!

0 Upvotes
New Member

I have this issue with Apple Mail as well! If I open a reply in my inbox, this counts as a read receipt for the lead.

New Contributor

do I have to reset the enable networks servives back to default? 

0 Upvotes
Regular Contributor

I always get an alert in Chrome that my client opened an email when I open a reply in Outlook (Mac). It's always been like this. 

Should it not do this? Will your solution help this too?

UPDATE: The solution above doesn't help for Mac Outlook. 

0 Upvotes
New Member

The solution doesn't help in case of Outlook because the changes suggested are limited to Google Chrome and unless you are using the web version of Outlook on Chrome, this is a pretty common occurence. 

0 Upvotes
New Contributor

I've also noticed that opens are shown if I read the email on my Honor 8 phone (the Hubspot app is also installed on that phone).

 

So the self-opening gets a bit confusing!

0 Upvotes
New Member

Thank you for the work around.  Are there any known negative effects of disabling?  Anything that we may experience elsewhere (meaning "known" issues, of course)? 

Occasional Contributor

It's been an issue for some time now. Please fix this. 

0 Upvotes
New Member

I have an android phone and other browsers - what impact will thishave on normal operations of network services (will email work/update on my phone ? etc)

0 Upvotes
New Contributor

Didn't worked for me!

0 Upvotes
New Member
 
0 Upvotes
New Contributor

No one can down vote? **bleep**!!!

0 Upvotes
New Member

ty

0 Upvotes
New Contributor

No down Vote sign??

0 Upvotes
Occasional Contributor

HI there, thanks for letting me know but can you elaborate more as to what this is, why it's happening before I go through the steps to fix?

 

Thank you!

 

Raegan

0 Upvotes
Regular Advisor

@Flora something like this has happened in the past. Is this an ongoing Chrome issue?

0 Upvotes
New Contributor

This was also happening with my Outlook 2013.

0 Upvotes
New Contributor
 
0 Upvotes
HubSpot Employee

We have been in communicaton with the Google team and this will be resolved in Chrome 73. Please use the documented solution here until then. 

 

Please note: this is specific to the Gmail extension. If you are seeing this issue in an email client without an extension such as a mobile device or Apple mail, please refer to this knowledge doc to block HubSpot Sales email open and click tracking from your own IP.

Occasional Contributor

To make it clearer:

If you open a tracked email, it will register as being opened unless one or more of the following is true:

1. The tracked email is opened in a Chrome web browser (version 73 or higher) that has the HubSpot browser extension running, whereby the extension overrides the "email was opened" report sent back to HubSpot;

 

2. The tracked email is opened in a Chrome web browser where the 

chrome://flags/#network-service is set to Disabled;

 

3. The tracked email is opened when there is no connection to the Internet, so a report cannot be sent back to HubSpot. (Best to close the email and archive/file it while still disconnected...);

 

4. The tracked email is opened while you ARE connected to the Internet, but your IP address or domain is blocked in HubSpot>Settings>Reports>Tracking Code>Advanced Settings>Exclude Traffic -- accessible by HS admins -- or via your HS Chrome extension per the instructions at https://knowledge.hubspot.com/articles/kcs_article/email-notifications/block-ip-address. (This is highly unlikely to work on a mobile phone connected to the mobile network, as your IP address changes often, meaning it is unlikely that your admin will constantly be updating the mobile IP address.)

 

Despite all these methods, it seems that tracked emails will sometimes register opens. Even though we all use Chrome with the HS extension installed (or the flag setting disabled), and our office IP address and domain are blocked, we often see open notifications when one of us in the office opens a tracked email.

 

So...Opening the email on your phone while on the mobile network, or opening it in anything except a Chrome browser with the HubSpot extension active, means that it WILL be recorded as an open. If you absolutely must not trigger an open, then disconnect from the Internet.

Occasional Contributor
This helps, but please address the question of whether we need to reenable network services or if there are any implications to disabling. Thank you.
0 Upvotes
Regular Advisor

@Flora Will this also correct the issue for mobile devices?

0 Upvotes
Occasional Contributor

I have done as you said but the issue persists. 

 

0 Upvotes
HubSpot Employee

If you are still seeing this persist in the Gmail Extesnsions, please update to Chrome to 72.0.3626.117 (or later) to resolve this issue. 

 

This update can be triggered by:

1) Go to: chrome://settings/help on Chrome

2) Waiting for update to download

3) Relaunching Chrome 

 

Thank you for everyone's comments and patience as we are working through this. The previous workaround should have no impact on your regular workflow and Chrome but if you have updated Chrome to 72.0.3626.117 or later, you can also undo the workaround. 

 

Let me know if there is more information I can provide! 

New Contributor

I disabled networking per your instructions, yesterday and it seemed to work. But, today the same old problem is continuing.

0 Upvotes