HubSpot Gmail extension not working on newest Brave browser

SOLVE
Highlighted
Top Contributor

Hello,

I'd like to report that HubSpot Gmail extension not working on newest version of Brave browser. In my Gmail I can just see button to reload Gmail and info "Sorry. It looks like your browser settings are blocking HubSpot Sales.". I check it also with clean, new installation of Brave browser with disabled any blockers at Gmail and Hubspot pages.

1 Accepted solution

Accepted Solutions
New Member

Most Chrome plugins work directly in Brave in my experience, but it's Brave's more aggressive privacy settings that cause the issue. (Which is why we're all using Brave anyway.) I was able to get it working by doing the following... 

 

In Brave if you head over to Settings->Advanced->Privacy and Security->Site Sttings->Cookies and site Data->Allow and add static.hsappstatic.net to the allowed cookies the plugin begins to work. 

 

Just keep in mind this will now allow HubSpot bypass privacy settings with requests from that site. Not sure if it works 100% yet, but I was able to get it to sign in and connect to my Inbox after doing this. It is reporting some trackers are being blocked, not sure if I'll have to enable those or not, but you can see those in the Shields Up area. 

4 Replies 4
New Member

Most Chrome plugins work directly in Brave in my experience, but it's Brave's more aggressive privacy settings that cause the issue. (Which is why we're all using Brave anyway.) I was able to get it working by doing the following... 

 

In Brave if you head over to Settings->Advanced->Privacy and Security->Site Sttings->Cookies and site Data->Allow and add static.hsappstatic.net to the allowed cookies the plugin begins to work. 

 

Just keep in mind this will now allow HubSpot bypass privacy settings with requests from that site. Not sure if it works 100% yet, but I was able to get it to sign in and connect to my Inbox after doing this. It is reporting some trackers are being blocked, not sure if I'll have to enable those or not, but you can see those in the Shields Up area. 

New Member

Perfect! This solved my problem too. Thanks so much!

Reply
0 Upvotes
New Member

Hi, just want to say that this fixed the problem for me too. Thanks very much.

New Contributor

Worked like a charm. Life saver

 

static.hsappstatic.net

Reply
0 Upvotes