Gmail not logging into hubspot sales CRM

Occasional Contributor

I am a new user. I have installed Gmail and followed the steps to sync up Gmail to CRM. Even after reinstalling, my emails are not logged, despite clicking log email checkbox.

 

The only way to solve it is to manually bcc as follows: --> copy paste "ourcompany hub id here"@bcc.hubspot.com and it works. But it is taxing to have to do this all the time. 

 

I tried hubspot support but unfortunately I've been told I cannot get tech support as a free hub user. The sales guy would not be able to get technical hence, only keen on upgrading my 'freemium'. Coming from a sales guy myself, this chicken-egg game is not right, by principle. A free service should be complete, else not have this functionality. It's not good for the customer journey, coming from a professional company. 

 

Would appreciate any help, and thanks so much Smiley Happy

31 Replies 31
HubSpot Moderator

Hi @mark2 We have some troubleshooting steps for failed logging listed here.

 

Ed 


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Occasional Contributor

Thanks Ed.

 

However it is exactly how it should be, forwarding and bcc:

myhubid@bcc.hubspot.com

myhubid@forward.hubspot.com

Nothing really helping me to troubleshoot. All the criteria are met, but this one I can't verify --> It states minimum user role is sales user. I believe so, since I can manually past a bcc to circumvent the log issue? 

 

Is it possible to get on a quick call to troubleshoot? 

Regular Contributor

having same issue!

Occasional Contributor

Mines not resolved too, if you know anything please let me know too and vice versa

Reply
0 Upvotes
Occasional Contributor

I'm having the exact same issue. The hubspot sidebar in gmail shows my activity. The hubspot website does not show anything until I manually enter it. HOWEVER the notifications page does show the activity. WHAT THE HECK is going on?? Everything is set up correctly.

 

issue.jpg

 

Reply
0 Upvotes
New Contributor

Hi,

My emails sent in gmail do not sync with hubspot.

I have gone through the troubleshooting. Everything is ticked, extension is installed, my emaiil is connected etc.

 

anything else i can try please?

 

thanks

New Member

Hi,

I have the same problem. When I send emails from my Gmail, the notifications are synced but the emails are not logged to HubSpot sales. Both "Log" and "Track" are checked, and I've sent the mails from the right address. Contacts are synced only if I click "Add to Hubspot" on the email sidebar.

 

Using Chrome on Mac.

New Member

I am having the same problem too! I've done all the troubleshooting I can find but nothing is working! I can see the email tracking on the side panel in gmail but not in the contact's timeline on HubSpot's CRM. 

New Contributor

any solutions?

Regular Contributor

same here! no email is being logged, all settings are correct...

Reply
0 Upvotes
Highlighted
New Contributor

I am having the same issue.  When I send emails from within the CRM they are logged as expected, but when using Gmail (Paid GSuite account) it does not log the emails against the contacts.  

Occasional Contributor

I'm having the same exact issue.

 

issue.jpg

Reply
0 Upvotes
Community Manager

Hi all,

 

I am going to merge this thread with an existing thread that outlines the troubleshooting issues for this so we can keep troubleshooting and communication streamlined. 

 

Thank you,

Jenny

 


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Regular Contributor

@jennysowyrda Hi Jenny, what do you mean by populated bcc field? I am using this method: https://knowledge.hubspot.com/articles/kcs_article/email/how-to-log-your-email-in-the-crm-using-hubs...

Is this not working anymore?

Reply
0 Upvotes
Regular Contributor

not working for me....   i installed the extension on chrome, but when i type an email to a contact in gmail it does not log in hubspot.

Reply
0 Upvotes
Regular Contributor

everything is ticked, log and track, but it does not show up in hubspot.

Reply
0 Upvotes
Occasional Contributor

Started working today. Talked with a great support rep, perhaps something just got fixed on the backend. Either way, I'm a happy camper now.

Reply
0 Upvotes
Regular Contributor

nope mine still isnt working.   i just tested it

Reply
0 Upvotes
Regular Contributor

please tell me what i am doing wrong......

 

1.   install chrome extension for gmail

2.  send email from gmail in chrome browser to a contact (myself for testing at a different gmail account)   

3.  tick boxes are checked   (by default anyway)

4.  log into hubspot and look up my contact (myself)

5.  I see no record of an email sent

6.  refresh after 5 minutes and still see no record.

 

it DOES work if I send the email from hubspot

but it DOES NOT work if I send it from Gmail.

 

I do have my company email set up through gmail also.....does that have anything to fdo with it????   I have tried sending from both my gmail address and my company address both via gmail.

 

Regular Contributor

I have cleared cache

 

I have checked all settings in chrome in the tutorial

 

everything is enabled.   

 

WHY WONT IT WORK!?????

Reply
0 Upvotes
Community Manager

@daniull if you can send me the information I've requested above I can look into this more. Based on what you are outlining it sounds as though you are doing everything correctly, so if you can send along the information I've mentioned (headers and screenshots), I'm happy to dig into this more on my end. 

 

@fabyogi when you send an email, you will see the bcc address in the 'sent' email. The bcc address will automatically populate if you have a connected inbox and are using the Chrome extension, but it should be added once you click the 'log' button. So if you can find an email you've sent and logged, then the bcc should show up in the sent email. 

 

Let me know if I can provide any further clarity around either of those points. 

 

Thanks,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Regular Contributor

I do not see the bcc addess for the track .    its not there....also doesnt that mess up if I wanted to send a bunch of bcc emails?    will the bcc track to the recipients also in bcc?

Reply
0 Upvotes
Community Manager

@daniull the bcc will be associated with the "log to crm" not the tracking funtionality. If you are not seeing the bcc address populating in your sent emails, this is why you are not seeing your emails logged in the CRM. 

 

Please send along screenshots showing that you are checking off the "log" option and then after you've sent it of the email in your sent folder showing no bcc address. If you can also send along a link to the contact record where the email should have been logged, that would be very helpful. 

 

Finally, please try manually inserting the bcc address into an email (and not checking off the "log") and see if that 1) shows the bcc address in your sent folder and 2) showing if that email did/or did not log on a contact record. Any screenshots of this would be very helpful as well. 

 

Thank you,

Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Regular Contributor

Hi Jenny, it seems to be working now. I didnt change anything but I think they fixed the bug or whatever.. Thanks anyways for your support!

New Contributor

Same problem. Help!

Reply
0 Upvotes
Community Manager

Hi @peterszijarto @mark2 @fabyogi

 

If you are still experiencing this issue can you please provide me with the following: 

1. A screenshot of an email sent from your connected inbox (showing the bcc address is populated) 

2. A link to the corresponding contact record that the email should have been logged on

3. The email header of the sent email

4. The email header of the delivered email (if you are able to send a test email to an inbox you can access, then this will be possible). 

 

You can send this through a direct message. 

 

Thank you,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Occasional Contributor

What is supposed to be in the bcc field?

 

I have seen nothing that says that should be populated. Is there documentation somewhere that outlines how to have the autofilled by the hubspot gmail integration?

Reply
0 Upvotes
Occasional Contributor

I have log and track clicked on in GMAIL and the gmail / chrome extension is turned on. I"ve disabled all other extensions.

 

The documentation does state I can use the bcc to log, but to have it automatically log, I am just supposed to click the log and track buttons.

Reply
0 Upvotes
Occasional Contributor

I think I figured out the issue! I did a test email and hit send in gmail. Then before the email is fully sent, gmail gives you the option of "UNDO". I did that.

 

That's when I noticed there is a bcc that appears. When click send again, the email shows up in my contact timeline as logged and tracked. Strange!