Cookie Error on Gmail Extension. Tried *EVERYTHING* help!

jasondainter
Member

Am trying to install the Hubspot Sales extension for Chrome.

I install this fine, then try to log in and I constabtly get the cookie error below.

I have already tried:


  • Updating chrome (up to date)
  • Clearing cookies (all of them)
  • Removing the plugin, reinstalling it
  • Disabling ALL my plugins temporarily, same issue (even after reinstalling)

Its a business gmail suite subscription.

I have no idea why this isnt working, please help, wasting endless time on it

ERROR BELOW:

Not logged in

 

Extension version: 2.9.0.5519
Chrome version: 91.0.4472.77
SDK: Kratos 0.1

 

Chrome alerts enabled: true

 

Log by default: false
Log default associations: {"newContactsDefault":null,"companiesDefault":null,"dealsDefault":null,"ticketsDefault":null}
Track by default: false

 

Extension errors:
- [background] - [HubSpot Sales] Detected csrf cookie on startup: {"domain":".hubspot.com","expirationDate":1653562502.949617,"hostOnly":false,"httpOnly":false,"name":"hubspotapi-csrf","path":"/","sameSite":"no_restriction","secure":true,"session":false,"storeId":"0","value":"VJODJ-CJ..."}
- [background] - Unable to fetchUser:
- [background] - [HubSpot Sales] Detected HUBSPOTAPI_CSRF_COOKIE_NAME cookie change Cause: overwrite Removed: true Cookie: {"domain":".hubspot.com","expirationDate":1653562502.949617,"hostOnly":false,"httpOnly":false,"name":"hubspotapi-csrf","path":"/","sameSite":"no_restriction","secure":true,"session":false,"storeId":"0","value":"VJODJ-CJ..."}
- [background] - [HubSpot Sales] Detected HUBSPOTAPI_CSRF_COOKIE_NAME cookie change Cause: explicit Removed: false Cookie: {"domain":".hubspot.com","expirationDate":1653562554.053426,"hostOnly":false,"httpOnly":false,"name":"hubspotapi-csrf","path":"/","sameSite":"no_restriction","secure":true,"session":false,"storeId":"0","value":"nnSvwpZY..."}
- [background] - [HubSpot Sales] Detected HUBSPOTAPI_CSRF_COOKIE_NAME cookie change Cause: overwrite Removed: true Cookie: {"domain":".hubspot.com","expirationDate":1653562554.053426,"hostOnly":false,"httpOnly":false,"name":"hubspotapi-csrf","path":"/","sameSite":"no_restriction","secure":true,"session":false,"storeId":"0","value":"nnSvwpZY..."}
- [background] - [HubSpot Sales] Detected HUBSPOTAPI_CSRF_COOKIE_NAME cookie change Cause: explicit Removed: false Cookie: {"domain":".hubspot.com","expirationDate":1653562568.079338,"hostOnly":false,"httpOnly":false,"name":"hubspotapi-csrf","path":"/","sameSite":"no_restriction","secure":true,"session":false,"storeId":"0","value":"1yMqyWFv..."}

 

Http logs:
- /login-api/v1/cookie-verify
- Request for https://api.hubspot.com/users/v2/app/sidekick failed with status 404.
- /login-api/v1/cookie-verify
- Request for https://api.hubspot.com/salesclients/v2/client-init failed with status 404.
- Request for https://api.hubspot.com/users/v2/app/sidekick failed with status 404.
- Request for https://api.hubspot.com/users/v2/app/sidekick failed with status 404.
- Request for https://api.hubspot.com/salesclients/v2/client-init failed with status 404.
- accounts/v1/accounts
- Request for https://api.hubspot.com/users/v2/app/sidekick failed with status 404.
- accounts/v1/accounts
- login-verify/echo/with-gates
- login-verify/echo/with-gates

 

Installed and enabled extensions:
 

 

Installed but disabled extensions:
 

 

Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/91.0.4472.77 Safari/537.36

 

0 Upvotes
4 Replies 4
jasondainter
Member

So took me a good 30 minutes to try and get this post unmarked as spam (thanks to whoever did that).

Any chance this could be answered? Its blocking me becoing a customer at the moment and time is not on my side.

0 Upvotes
PamCotton
Community Manager

Hello @jasondainter, thank you for posting in our Community, apologize if this post was in our spam inbox, sometimes if you shared an external link it can tag as spam.

I checked with our team, could you please ensure that you checked to see if it's blocking third-party cookies? More information here.

 

Thank you,

Pam

 

Você sabia que a Comunidade está disponível em outros idiomas?
Participe de conversas regionais, alterando suas configurações de idioma !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !




jasondainter
Member

It suddenly worked now when I tried on my desktop at home, so it must have been a local browser issue on my laptop and not server side anyhow. Thanks can close this.

0 Upvotes
PamCotton
Community Manager

Hi @jasondainter, thank you for letting us know! I'm glad this is fixed! 

 

Kindly,

Pam

Você sabia que a Comunidade está disponível em outros idiomas?
Participe de conversas regionais, alterando suas configurações de idioma !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !