'Connect with your email' not working

Highlighted
New Contributor

Using OS X 10.12.3, Chrome 56.0.2924.87. Using a Google business email address through Gmail.

 

Have tried connecting email via Setup progress, Settings, Contact email screens. All give a success message and then show the same message to 'Connect with your email'.

 

Have cleared cache, tried as Incognito. Also tried in Safari.

 

I was trialling a Hubspot account with the same email address years ago. Have removed that Hubspot account but maybe there is still some link behind the scenes causing this?

 

Have colleagues using same Gmail addresses that have successfully connected to Hubspot.

 

Oh, and 'All mail' check box is ticked in Gmail settings, labels...

 

Thanks...

Reply
0 Upvotes
3 Replies 3
Highlighted
HubSpot Employee

Hello @mattfordham,

 

This page will show all of the connected apps that you have connected to your inbox.  If you see Hubspot listed, can you please click on it, then click 'Remove' and attempt to re-connect your inbox from within Hubspot?  

 

Let me know if this changes anything.

Brett

Reply
0 Upvotes
New Contributor

Thanks Brett, unfortunately didn't work. It did reappear in the Google list after I reconnected from within Hubspot. However, Hubspot is still asking me to connect again.

Reply
0 Upvotes
Highlighted
Regular Contributor

Hello!

 

My colleague is also having this problem! I've tried the suggestion that was listed and that didn't work! Is there anything else you've tried?

Reply
0 Upvotes