GDPR

peppereffect
Participant

HubSpot Forms not working with Cookiebot and Tag Manager

SOLVE

Hello all,

 

I'm running into a really strange issue and cannot find a solution.

In order to align with GDPR I'm using Cookiebot on my website, which is integrated via Google Tag Manager. I'm also using HS forms for my contact page.

After the first scan of Cookiebot all HS cookies are categorized as marketing cookies.

If a user now just accepts the necessary cookies and not the marketing cookies, the HS form is not shown on the contact page.

If a user accepts the marketing cookies, the HS form is shown.

So I tried to move all HS cookies from marketing to necessary cookies but nothing changes. Even if there is no cookie within the marketing category, the form is just shown in case the user is accepting the empty marketing cookies category. 

 

What am I doing wrong? Which cookies need to be accepted in order to get the HS form running?

 

Thank you for your reply.

1 Accepted solution
MatthewShepherd
Solution
HubSpot Moderator
HubSpot Moderator

HubSpot Forms not working with Cookiebot and Tag Manager

SOLVE

Hi @peppereffect 

 

Cookiebot is a great tool but can be tricky to get working correctly, particularly when Google Tag Manager is involved. Can you let me know:

 

  1. Did you follow this Google Tag Manager deployment guide?

  2. Are you using auto or manual cooking blocking mode?

  3. Are you loading your Hubspot tracking script via Google Tag Manager, and if so is it firing based on a Cookiebot cookie_consent trigger?

Matthew Shepherd

Senior Inbound Consultant

Professional Services | HubSpot

He/Him

linkedin.com/in/matthewshepherd/
https://www.hubspot.com/services/professional

View solution in original post

9 Replies 9
CMarritt
Contributor

HubSpot Forms not working with Cookiebot and Tag Manager

SOLVE

Hi! 

We are having the same problem which landed me on this thread, i scanned your website to see if it was compliant and it looks like it isnt due to the way the form is loaded. To me this feels like a Hubspot form issue, the cookie responsible is called embed/v3/counters.gif, if this is set to necessary in cookiebot, the form loads perfectly. however, this is not GDPR and Privacy compliant as upon submissions the form still tracks the user journey around the website. This Cookie/script needs to be divided into two, 1 script for loading the form and another for the tracking 

Capture2.PNG

0 Upvotes
Martin11
Member

HubSpot Forms not working with Cookiebot and Tag Manager

SOLVE

Hi, I think the hubspot formula you use on your website is technically important that the website works and so the cookie is in my opinion necessary and not a marketing cookie. 

0 Upvotes
MatthewShepherd
Solution
HubSpot Moderator
HubSpot Moderator

HubSpot Forms not working with Cookiebot and Tag Manager

SOLVE

Hi @peppereffect 

 

Cookiebot is a great tool but can be tricky to get working correctly, particularly when Google Tag Manager is involved. Can you let me know:

 

  1. Did you follow this Google Tag Manager deployment guide?

  2. Are you using auto or manual cooking blocking mode?

  3. Are you loading your Hubspot tracking script via Google Tag Manager, and if so is it firing based on a Cookiebot cookie_consent trigger?

Matthew Shepherd

Senior Inbound Consultant

Professional Services | HubSpot

He/Him

linkedin.com/in/matthewshepherd/
https://www.hubspot.com/services/professional
peppereffect
Participant

HubSpot Forms not working with Cookiebot and Tag Manager

SOLVE

Hi @MatthewShepherd ,

 

thanks for your reply and I'm sorry for my late response. I thought that I solved the problem myself but it is still happening. So answering your questions: 

1. I followed the deployment guide.

2. I'm using the auto cookie blocking mode.

3. Yes, the HubSpot tracking script is loading via Google Tag Manager and has a trigger, which is Cookie Consent Statistics.

 

Strange thing though, the form is only appearing when one accepts the Marketing cookies in the cookie banner. If someone accepts the Statistics cookies but not Marketing, the form is not showing.

 

Any idea how I get the HubSpot form displayed on my contact page even if the user just accepted the necessary cookies?

 

Thank you in advance,

 

Peter

0 Upvotes
MatthewShepherd
HubSpot Moderator
HubSpot Moderator

HubSpot Forms not working with Cookiebot and Tag Manager

SOLVE

Hi @peppereffect  - can you share the URL where you are experiencing this issue?


Matthew Shepherd

Senior Inbound Consultant

Professional Services | HubSpot

He/Him

linkedin.com/in/matthewshepherd/
https://www.hubspot.com/services/professional
0 Upvotes
peppereffect
Participant

HubSpot Forms not working with Cookiebot and Tag Manager

SOLVE

Hey @MatthewShepherd ,

 

this is the page I'm talking about: https://peppereffect.com/kontakt/

At the moment I'm looking for alternatives for the HS forms so in case you can detect the issue, it would be really much appreciated.

 

Thank you for your effort and time.

 

All the best,

 

Peter

0 Upvotes
MatthewShepherd
HubSpot Moderator
HubSpot Moderator

HubSpot Forms not working with Cookiebot and Tag Manager

SOLVE

@peppereffect 

 

I noticed your form embed code is set to data-cookieconsent="marketing", did you set that manually in your code? If so can you try removing that from the code as this script would be considered necessary for functionality rather than for marketing.

 

<script type="text/plain" data-cookieconsent="marketing">
	hbspt.forms.create({
	portalId: 6296000,
	formId: "d1bade83-f399-479f-bfcb-68a11f8b48a2",
	shortcode: "wp",
	});
</script>

Matthew Shepherd

Senior Inbound Consultant

Professional Services | HubSpot

He/Him

linkedin.com/in/matthewshepherd/
https://www.hubspot.com/services/professional
peppereffect
Participant

HubSpot Forms not working with Cookiebot and Tag Manager

SOLVE

@MatthewShepherd thank you so much. It is finally working and was caused by the wrong embeded code, like you said. I didn't insert the wrong part but used the HS-plugin, which created a shortcode and just used that one. This time I used the code from HS web directly and now it's working just fine.

 

@Martin11 thank you for confirming.

 

All the best and I appreciate your help Matthew.

MatthewShepherd
HubSpot Moderator
HubSpot Moderator

HubSpot Forms not working with Cookiebot and Tag Manager

SOLVE

@peppereffect great! Glad you got it fixed.


Matthew Shepherd

Senior Inbound Consultant

Professional Services | HubSpot

He/Him

linkedin.com/in/matthewshepherd/
https://www.hubspot.com/services/professional
0 Upvotes