Hidden hubl values in form stopped working after March 2nd

Highlighted
New Contributor

I have a contact form on my site that has a couple of hidden hubl fields. These fields contain information about which web page the form came from.. Since March 2nd the hidden hubl fields no longer pass their information to the final submission  of the form nor does that hidden data end up being added to the contact information. The fields that aren't hidden, which the visitor enters their data into, is received but not the hidden "pre-programmed" fields. The hidden field values are also part of a workflow which is not being activated as the values are being lost prior to the workflow getting the values. One hidden value is working as it contains a redirect URL, but the other 3 fields that contain data to be added to the visitor's contact is not. 

 

I have checked the code in the custom module that handles this form and nothing has changed in it... The last change to the form was in 2016 and it has not been touched since. 

 

I am not sure where else to look as nothing has been touched that I can see on my end that would cause this form to not pass the hidden field values. Did something change in the last few weeks with how widgets are handle data?

Reply
0 Upvotes
3 Replies 3
Highlighted
Community Superstar


2000px-Ok_sign_font_awesomeDid my post help answer your query?

Help the Community by marking it as SOLVED

 

Q: Hidden hubl values in form stopped working after March 2nd

Short A: Sounds like a question for the orange Oompa Loompa's at HubSpot Support. haha

 

Longer A: Only more questions ...

 

-1- Is your site hosted on HubSpot?

-2- Have you tested the form on a HubSpot Landing Page with the same result?

-3- Can you reproduce this anamolous behavior with a clean new form on a HubSpot hosted page?

 

Answer 'yes' to all of the above questions and definitely need to go to orange Oompa Loompa land.

 

hubspot-forum-signature-badge-v01.png

 

Note: HubSpot is a constantly evolving platform. Please check the date of each post and view all solutions in that context.

-- Visit

 

Hope that helps.

 

Be well,
Frank


Support • Web • Apps • Training

HubSpot's Hiring World-Wide!

Highlighted
New Contributor

Yes. The site is hosted on Hubspot and this issue is affecting 100+ sites that use this same form. I talked to support yesterday they have a team working on it since it is not my code as the code in the global module and the form itself hasn't changed in years.

Reply
0 Upvotes
Highlighted
Esteemed Contributor | Gold Partner

> if you debug the form, using inspect element, do you see the hidden fields ?

 

> i don't know if this has anything to do with it, but do you have collected forms activated on your hubspot portal? It's something recent and I don't know if by creating this new feature maybe hubspot introduced a bug?

 

Try disabling it.. or otherwise try enabled, and test what happens..
I personally like it disabled otherwise the hubspot just saves ALL form data.. (and it's not very GDPR complient in many cases)

 

https://knowledge.hubspot.com/getting-started-with-the-hubspot-crm-free/how-to-use-the-collected-for...