Hola! ¡Tenemos nuestra Comunidad en Español!

Double Opt-In Toggled Off After Email Setup Wizard

Highlighted
New Contributor

I am a free user, and I created my first pop-up form. In the "follow-up" step, I set up double email opt-in per these instructions (for free users). However, when I enter my email on the form as a user, I never receive the double opt-in email. The contact I created through the form as well as at least one real customer's form submission have the error "There was an issue sending an email to this contact. This recipient has unsubscribed from this subscription type." (which isn't true) 

 

In settings->marketing->email, double opt-in appears to be toggled OFF, and clicking it to turn on gives me the error "Upgrade to Marketing Starter to turn off double opt-in and manage your opt-ins based on how you do business."

 

Anyone have any idea how to re-generate the double opt-in setup wizard in forms (going back through the setup flow doesn't appear to take you through the wizard again) OR get the double opt-in to toggle on in settings?

Reply
0 Upvotes
3 Replies
HubSpot Moderator

Hey kellyannefitz!

 

The Send double opt-in email feature is enabled by default in Marketing Free accounts. In order to disable the feature, you'll need to upgrade to Marketing Hub Starter.

 

Have you tried accessing the double opt-in settings from the 'Options' tab in your forms editor? You should be able to find a box labeled, "Send opt-in emails." In order to edit double opt-in settings, you will need to have first configured an email footer.  Give that a shot and let me know how it goes. 

 

- Zakiya

New Contributor

The problem is not that it was toggled ON and should have been OFF, but rather the reverse. It was OFF and I could not get it to turn on, despite having gone through the double opt-in setup wizard when creating my first form. 

 

The solution was going through the form setup again, deleting the followup email I had created, and then creating the follow up email again. This regenerated the double opt-in setup wizard and toggled the double opt-in in settings ON.

 

Clearly there was a bug or something going on, but that's how you would resolve it, if anyone else encounters this issue. 

HubSpot Moderator

Glad to hear you were able to find a solution! It is definitely odd that the setting was toggled OFF to start. Thanks for sharing your workaround!