Fehler bei der Synchronisierung HubSpot -> Mailchimp

Highlighted
Mitwirkender

Bei der Einsendung auf einem HubSpot Popup und der anschl. Synchronisation mit Mailchimp gibt es einen Fehler. Die Fehlermeldung lautet:

---

Beim Synchronisieren mit Mailchimp ist ein Problem aufgetreten.


400 Invalid request due to malformed resource path or data: {"type":"http://developer.mailchimp.com/documentation/mailchimp/guides/error-glossary/","title":"Invalid Resource","status":400,"detail":"The resource submitted could not be validated. For field-specific details, see the 'errors' array.","instance":"0d30f985-55ee-49dc-b8bb-72d533211f0e","errors":[{"field":"merge_fields.PHONE","message":"Data did not match any of the schemas described in anyOf."},{"field":"merge_fields.ADDRESS","message":"Data did not match any of the schemas described in anyOf."}]}

 

Der Link auf "Was bedeutet das?" führt leider ins Leere:
http://support.leadin.com/hc/en-us/articles/205980135

Antworten
0 Like / Likes
7 ANTWORTEN 7
Moderator

Hi @adiehl

 

Könntest du mir noch genauer sagen wo genau der Fehler auftritt und mir gegebenfalls einen Screenshot senden?

 

Zusätzlich würde ich dir zudem raten, die Installation in einem anderen Browser und/oder in einem inkognito Fenster zu versuchen. 

 

Dieser Fehler deutet darauf hin, dass deine Merge-Tags innerhalb von Mailchimp nicht korrekt eingerichtet sind. Könntest du einmal sicherstellen, dass diese korrekt eingerichtet sind? Dann sollte dieser Fehler verschwinden. Mehr Infos findest du hier. 

 

Da Mailchimp keine native HubSpot-Integration ist haben wir sehr wenig Möglichkeiten und Einblicke in die Integration. Ich würde dir daher auch raten, dich an den Mailchimp Support hier zu wenden. 

 

Ich hoffe, das hilft dir! 

Mitwirkender

Danke.

 

Wo genau kann ich dir nicht sagen, ich sehe es nur in den E-Mail Einstellungen (anbei).

 

Zudem verwende ich nur E-mail und Vorname, das hat bisher einwandfrei funktioniert. Anbei ...

 

1. Einstellungen Audience Merge Tags bei Mailchimp

2. Einstellungen Formulare bei HubSpot

 

Die einzigen Ideen die ich habe, den Vorname bei Mailchimp auf "required" zu setzen und / oder das Feld "erforderliches Interesse" bei HubSpot auf "keine" zu setzen.

 

Sonst noch Hinweise / Ideen?

 

Viele Grüße,

Andreas

Screenshot 2020-01-30 at 19.01.33.pngScreenshot 2020-01-30 at 18.56.15.png

Mailchimp_Merge.png

 

Antworten
0 Like / Likes
Moderator

Hi @adiehl,

 

Gerne kannst du versuchen es mal mit den required Feldern zu versuchen. 

 

Hast du denn auch mal auf "Neu konfigurieren" geklickt? Ich kann sehen, dass auch dort ein Problem vorliegt. 

 

Auf welche Seite kommst du denn, wenn du auf "Was bedeutet das?" klickst?

 

Antworten
0 Like / Likes
Mitwirkender

Danke.

 

Wen ich auf "was bedeutet das" klicke, dann komme ich auf diese Seite.

 

Ich habe mittlerweile:

- Die Verbindung getrennt, neu konfiguriert

- den Vorname auch als reqquired field gesetzt

 

Leider ohne Erfolg.

 

 

 

 

Antworten
0 Like / Likes
Moderator

Hast du schon einmal hier nachgeschaut?

Das sind die häufigsten Fehler. 

 

Auch diese Mailchimp eigene Resource hier könnte dir nützen. 

 

Antworten
0 Like / Likes
Mitwirkender

Danke. Da finde ich jedoch noch keine Lösung.

 

Die Fehlermeldung enthält ja einen Verweis auf fehlende Felder. Das Verrückte ist, dass ich diese Felder im Formular gar nicht habe (und auch nich bei Mailchimp). Ich habe sie einfach mal bei Mailchimp zugefügt, was aber auch nichts ändert.

 

Aktueller Status:
- Ich frage Vorname und Mail in einem HubSpot Popup Formular ab
- In Mailchimp habe ich vier Merge Tags (E-Mail (required), First name, Phone, Adress (optional))
- HubSpot protokolliert einen Fehler (siehe oben oder am Ende des Posts)

- Ich drehe mich im Kreis.Smiley (fröhlich)

 

Fragen:
- gibt es eine Einstellung, mit der ich HubSpot und die Mailchimp Formularfelder gegeneinander mappe?

- Ist das nun ein HubSpot Fehler oder ein Bug bei Mailchimp?

- Ist das denn bei HubSpot richtig aufgehoben oder muss ich mich damit einfach mal an Mailchimp Support wenden, wenn ja habt ihr bei HubSpot da nicht direktere Connections, das mal auf kurzem Dienstweg zu checken, was da die Ursache sein kann?

 

Hier nochmal der Fehler:

---

400 Invalid request due to malformed resource path or data: {"type":"http://developer.mailchimp.com/documentation/mailchimp/guides/error-glossary/","title":"Invalid Resource","status":400,"detail":"The resource submitted could not be validated. For field-specific details, see the 'errors' array.","instance":"074051c5-0942-4079-ae80-1d63eccb446b","errors":[{"field":"merge_fields.PHONE","message":"Data did not match any of the schemas described in anyOf."},{"field":"merge_fields.ADDRESS","message":"Data did not match any of the schemas described in anyOf."}]}

---

Antworten
0 Like / Likes
Mitwirkender

Es geht wieder. 

 

Ich habe zwar nix mehr gemacht / probiert, aber die Kontakte werden nun wieder gesynct.

Antworten
0 Like / Likes