Email Marketing Tool

CTheilig
Member

Personalization Tokens Not Working

SOLVE

Hi there, 

 

I have issues with personalization tokens concerning First Name, Company name and Source. I can see the tokens working in a test email to myself (with the second lined filled out - sent to my other email address). 

 

In my Contacts, each of the fields from the token I use got something in it. 

It basically a first outreach email, GDPR is all enabled, all opted in. It was a mix of Static & Active lists - both showed the default versions I put in. 

 

I really don't see what is missing. Can anybody help? 

Thank you!

0 Upvotes
1 Accepted solution
karstenkoehler
Solution
Hall of Famer | Partner
Hall of Famer | Partner

Personalization Tokens Not Working

SOLVE

Hi @CTheilig,

 

When you access a sent email under Menu > Marketing > Email and click on the View email preview image, this will show you the default version of the email. You wouldn't be able to tell from this preview whether personalization has worked or not.

 

Same goes for the preview when you're editing an email and click Actions and Preview on the upper right. HubSpot wouldn't know which contact to preview this email for by default – you have to select it.

 

Be default, you're always looking at a non-personalized email – unless you select a contact-specific preview.

 

When you preview the email for a specific contact (Actions > Preview > Preview as a specific contact), and either First Name, Company or Source are missing, it's very likely that this information is not stored on the contact record.

 

You can check by navigating to the contact you're currently previewing the email for. Navigate to Menu > Contacts > Contacts, find the contact and click View all properties in the left sidebar. Search for First Name, Company or Source. If you find a value in these fields but the preview didn't show them, that's a bug. If the fields in the property overview do not have a value, that's why they don't show up in the preview.

 

Hope this helps!

Karsten Köhler
Digital Marketer | HubSpot Freelancer | CRM Consultant

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.

View solution in original post

6 Replies 6
karstenkoehler
Solution
Hall of Famer | Partner
Hall of Famer | Partner

Personalization Tokens Not Working

SOLVE

Hi @CTheilig,

 

When you access a sent email under Menu > Marketing > Email and click on the View email preview image, this will show you the default version of the email. You wouldn't be able to tell from this preview whether personalization has worked or not.

 

Same goes for the preview when you're editing an email and click Actions and Preview on the upper right. HubSpot wouldn't know which contact to preview this email for by default – you have to select it.

 

Be default, you're always looking at a non-personalized email – unless you select a contact-specific preview.

 

When you preview the email for a specific contact (Actions > Preview > Preview as a specific contact), and either First Name, Company or Source are missing, it's very likely that this information is not stored on the contact record.

 

You can check by navigating to the contact you're currently previewing the email for. Navigate to Menu > Contacts > Contacts, find the contact and click View all properties in the left sidebar. Search for First Name, Company or Source. If you find a value in these fields but the preview didn't show them, that's a bug. If the fields in the property overview do not have a value, that's why they don't show up in the preview.

 

Hope this helps!

Karsten Köhler
Digital Marketer | HubSpot Freelancer | CRM Consultant

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.

karstenkoehler
Hall of Famer | Partner
Hall of Famer | Partner

Personalization Tokens Not Working

SOLVE

Hi @CTheilig,

 

List membership shouldn't affect whether personalization tokens are displayed or not.

 

Could you provide more context on how you noticed that the tokens aren't working? Were you sending an email to a list and you heard back from recipients that the emails were not personalized?

 

Have you tried to preview the email for all of the contacts who did not receive correctly personalized emails? This is the first thing I would check, making sure that HubSpot actually has all of the data to pull into the personalization.

 

A screenshot from the part of the tool where you type/draft the email, showing the personalization tokens, could help, yes.

 

Best regards!

Karsten Köhler
Digital Marketer | HubSpot Freelancer | CRM Consultant

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.

CTheilig
Member

Personalization Tokens Not Working

SOLVE

Hi Karsten, 

 

Sure - at some point I went into the Email I had sent, click left on 'View Email' and saw the tokens weren't used. 

 

This is how I drafted it:

Tokens Used.png

That's the email that got sent:

Result.png

If I go into an email - to the 'Send or Schedule' section, and then 'Recipients' I select my list or person and go to Preview - it also doesn't show the token. Unless I pick a 'preview as a specific contact' specifically. 

 

The Personalization token First Name in the email subject line however worked. 

 

All the fields within Contacts are filled with the info for the tokens, the info should be there to take. Or is this a matter of Companies vs Contact? 

 

Any idea?

Thank you!

 

 

0 Upvotes
Kate8288
Participant

Personalization Tokens Not Working

SOLVE

I have the same problem, only where I inserted the Token for Company Name, it leaves a blank space. For example, How are things at  ?

0 Upvotes
karstenkoehler
Hall of Famer | Partner
Hall of Famer | Partner

Personalization Tokens Not Working

SOLVE

Hello @CTheilig,

 

When you preview the email for a contact on your list (as explained here), does the correct personalization show? Could you try to add a personalization token for the contact's email and test it on yourself (both preview and test send)? Since each recipient must have an email address, that's a way to check if something is fundamentally broken.

 

Could you also share a screenshot of the email in your email editor?

 

Best regards!

Karsten Köhler
Digital Marketer | HubSpot Freelancer | CRM Consultant

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.

CTheilig
Member

Personalization Tokens Not Working

SOLVE

Hi Karsten, 

 

Thanks for your quick reply. 

 

I should have added - I am able to send an email with the correct tokens if I specifically select one contact (that's not in any list). It just went wrong sending it to whole lists, static and/or active. 

 

What do you mean by email editor - where I draft it or 'Marketing Email' section?

 

Thanks for helping!!

Christin

0 Upvotes