Outlook Booking link not working with auto parameters

mkarsten
Top Contributor

We sent an email after checking an inline link to an Outlook booking calendar in the body. It was fine in the preview, but became aware it wasn't working in the email after it was sent. Found that the sent email is auto populating parameters, which I'm sure are for analytics. Problem is, Outlook doesn't like these parameters, and it goes to a page that says "Bad Request".

 

I knew parameters were added for CTAs, but didn't realize they're added to inline links. Is there a way to block the parameters from being added for the inline links for these types of cases?

0 Upvotes
5 Replies 5
sharonlicari
Community Manager

Hey @mkarsten 

 

I'd recommend reviewing this post where you can find the different reasons why this could be happening. I'm curious to know what other users have implemented. 

 

Hey @Kevin-C @Mike_Eastwood  @Mike_Donnelly any tips you can share with @mkarsten?

 

Thanks

Sharon


¿Sabías que la Comunidad está disponible en Español?
¡Participa hoy en conversaciones en el idioma de tu preferencia,cambiando el idioma en tus configuraciones!

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


mkarsten
Top Contributor

Sharon – Thanks so much for a great resource. We'd like to keep tracking on and only block this one link from having the parameters, so changing the email Settings isn't an option for us, but I've passed on the External system settings option to our Office365 admin to see if we can work it out on that end. I'll note here if we find it can be dealt with on that end.

 

0 Upvotes
Mike_Eastwood
Key Advisor | Gold Partner

Hi @mkarsten 

 

When you send an email, with Track selected, HubSpot swaps your link for a HubSpot link (with the URL parameters).

 

This new link allows HubSpot to track how many times the link is clicked from an email.

 

So, if you turn off Tracking in your email you can send the original URL unchanged, but you lose the tracking ability.

 

It sounds unusual thet the link is breaking (Bad Request).

 

Feel free to share (here or a private message) the links (original and HubSpot's version) and I can take a look.

 

Cheers

Mike

mkarsten
Top Contributor

I sent you a message with the links.:)

mkarsten
Top Contributor

I tried to reply to your solution in the private message, but I got an error, and now it says "You have reached the limit for number of private messages that you can send for now." So weird, I rarely use private message on this system.

 

Anyway, your suggestion to try a shortlink, was a good one!:) At least it led me to a slightly different path. We tend to avoid short links for bulk emails since ISPs occasionally blocklist URL shorteners, and there are some other cons that go along with that practice.

 

Instead I created a vanity URL using a proprietary web admin tool (thinking it should work the same if redirecting directly in HubSpot). Like you mentioned, the parameters were added to the redirect link in the email, so the URL of the final destination was clean and worked correctly when tested.

 

I'd like to give you credit for the solution if you want to post your private message here.:)

0 Upvotes