Issues with "From" Tokens in Marketing Email

SOLVE
Highlighted
Occasional Contributor

I am on the free CRM and trying to send a Marketing Email and getting the following two errors:

 

Screen Shot 2020-03-11 at 12.01.54 PM.png

For the first error about the default value for the Owner Full Name toke, I tried to edit it and was told that "You don't have permission to edit default values. Contact your admin for access." But I'm the admin...so...any ideas?

 

For the second error, that info about tokens in the From address seems to contradict the Knowledge Base article here. So I'm a bit at a loss. One weird thing is that unlike with the From name, the token wasn't available by default, so I manually typed it in...

 

Thanks for any help!!

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Highlighted
Occasional Contributor

UPDATE: My account got adjusted to a trial of the Professional bundle and this issue went away, so it appears to have been an undocumented limitation of the Free CRM software. I have notified HubSpot to update their documentation.

Reply
0 Upvotes
3 Replies 3
Highlighted
New Contributor | Platinum Partner

Hi @rberger 

 

To insert a token in the From Email field click on Add/manage next to this field and click personalize at the bottom.

 

Choose Contact owner in the first dropdown and select Email in the second dropdown like so:

 

Screenshot 2020-03-11 at 17.18.55.png

 

You should follow these same steps for the From Name, but select Full Name instead of Email in the second dropdown.

 

Default values for these fields are found in Settings > Marketing > Email. On the first tab "Configuration" scroll down to the bottom and you will see the section where you can set the defaults.

 

In Contact property defaults click on Edit Defaults, search for Contact Owner and then select a default user to be used as the fallback.

 

Hope that helps,

Tom

Highlighted
Occasional Contributor

Thanks for the reply @TomAshford !

 

For the tokens, I'm managing that here in the Settings section of my Marketing Email:

 

Screen Shot 2020-03-11 at 1.33.02 PM.png

 

So that appears to be a different place from where you're suggesting I handle it right?

 

Re: editing defaults, that's where I was trying to do it, but I was told I don't have access.

Reply
0 Upvotes
Highlighted
Occasional Contributor

UPDATE: My account got adjusted to a trial of the Professional bundle and this issue went away, so it appears to have been an undocumented limitation of the Free CRM software. I have notified HubSpot to update their documentation.

Reply
0 Upvotes