Developer Announcements

rhenry
HubSpot Employee
HubSpot Employee

Change to behaviour between GET and POST Contacts V1 endpoint


What's Happening?

We are making a change to the current inconsistent behaviour between the GET and POST Contacts V1 endpoints. 

What's Changing?

Currently if you request the Get a contact by email address endpoint and your request includes invalid characters like this example: (notice the invalid characters in the email address <>)

GET /v1/contact/email/<test.contact@testcompany.com>/profile 
A 200 server code is returned with the contact details in the response and the invalid characters get removed from the email address.

If you then create a contact using the Create a new contact endpoint and include invalid characters (<>) in the email address:

POST /v1/contact/email/<
test.contact@testcompany.com>/profile
A 400 server code is returned along with this error message:
404 OBJECT_NOT_FOUND "The contact <test.contact@testcompany.com> does not exist"

The GET request normalizes the email address and removes the invalid characters, but the POST request does not.


Today we will be changing this behaviour and normalizing email addresses for the Create a new contact endpoint (i.e removing invalid characters) so the behaviour is consistent with the Get a contact by email address endpoint. 

 

 

When is this happening?

The change is effective from today, October 29th, 2021.

Please let us know if you have any questions by replying below.


Rahmona Henry

0 Replies

No replies on this post just yet

No one has replied to this post quite yet. Check back soon to see if someone has a solution, or submit your own reply if you know how to help! Karma is real.

Reply to post

Need help replying? Check out our Community Guidelines