Content Strategy & SEO

janz
Participant

Problem with SSL for primary domain and redirect domain setup

Hi everyone,

 

I'm having with SSL cert after setting a redirect to the primary page in Hubspot. It seems that the cert is only created for the primary page not for the redirect domain that points to the primary domain.

I can only access the primary page from the first time I load the page(cleared cache and cookies). Any time after I get an error page with "The client and server don't support a common SSL protocol version or cipher suite"

In order for the cert to work it has to cover two domains .com and .pl but it is not the case. Is there any way to sort it out?

 

Thanks for help

Max

0 Upvotes
11 Replies 11
Jnix284
Most Valuable Member | Elite Partner
Most Valuable Member | Elite Partner

Problem with SSL for primary domain and redirect domain setup

Hi @janz thank you for all of the screenshots. I'm happy to confirm that your website is now working as expected, when I go to pradzdrewna.pl it redirects to pradzdrewna.com successfully:

Jnix284_2-1713787054111.png

 

Whatever the issue was, it looks like it resolved itself - this is not uncommon with new website domains and SSL provisioning. It can take between 24-48 hours for everything to fully go live, sometimes it's as quick as a few minutes, usually between 3-4 hours.

 

Please let me know if there's anything further I can do to help!

 


If my reply answered your question please mark it as a solution to make it easier for others to find.



Jennifer Nixon - Delivery Lead at Aptitude 8

connect with Jen on Linkedin

0 Upvotes
janz
Participant

Problem with SSL for primary domain and redirect domain setup

Hi @Jnix284, first of all, thanks for looking into it.

When you go to pradzdrewna.pl for the first time(cleared cache in the browser) it does work(redirects to pradzdrewna.com) but if you type in the URL pradzdrewna.pl within a couple of minutes the second or third time there is an issue with SSL. Video attached. It is random, which makes it kind of worse to diagnose.

https://youtu.be/PIQ6is_mgVA

0 Upvotes
Jnix284
Most Valuable Member | Elite Partner
Most Valuable Member | Elite Partner

Problem with SSL for primary domain and redirect domain setup

Hi @janz I'm not able to view the video, it's private - but I've also tried opening the website from both links multiple times in different browsers and incognito and can't get any sort of SSL error to trigger.


Can you try clearing your browser cache and/or incognito to see if the same thing continues to happen?

 


If my reply answered your question please mark it as a solution to make it easier for others to find.



Jennifer Nixon - Delivery Lead at Aptitude 8

connect with Jen on Linkedin

0 Upvotes
janz
Participant

Problem with SSL for primary domain and redirect domain setup

@Jnix284 Apologies, just made the video public, you should be able to view it now. 
I did try the incognito mode too, in multiple browsers chrome and firefox, same thing.

Thanks

0 Upvotes
Jnix284
Most Valuable Member | Elite Partner
Most Valuable Member | Elite Partner

Problem with SSL for primary domain and redirect domain setup

Hi @janz thank you for the video, I know what's happening and I don't think you should expect this would happen to your visitors:

 

1 - you're going directly to pradzdrewna.pl, which is using the non-secure http in the background (not visible unless you click into the nav bar) and redirects immediately to https://pradzdrewna.com/

 

2 - you're then changing the url https://pradzdrewna.com/  to https://pradzdrewna.pl and it loads the first time because of cache

 

3 - when you change the URL in the nav bar again, the browser recognizes that it is https and not http (not matching the cache) which results in the cipher mismatch

 

Are you advertising the site as .pl or .com?

 

How would someone arrive at .pl instead of .com?

 


If my reply answered your question please mark it as a solution to make it easier for others to find.



Jennifer Nixon - Delivery Lead at Aptitude 8

connect with Jen on Linkedin

janz
Participant

Problem with SSL for primary domain and redirect domain setup

Hi @Jnix284 

Good to hear from you.

We normally advertise the .com site. However, customers memorize the domain name and search/try to access the .pl site. I didn't notice the issue myself. It's the customer that came to us and let us know about it.

 

I understand the issue you diagnosed but I have no control over what customers type in the URL. As HubSpot is provisioning SSL automatically I don't have any control over it either.

 

Do you know if there is any way I can change our  DNS/Hubspot or our DNS  configuration so we can fix the issue?

 

Alternatively, can Hubspot SSL cover .com and .pl sites? I think it's already using wildcard cert to accept all the aliases anyway.

 

PS>> I'm still getting a warning when I go to .pl site SSL Verification...Cloudflare validation

The validation of the hostname ownership has failed. We're unable to issue an SSL certificate.

0 Upvotes
Jnix284
Most Valuable Member | Elite Partner
Most Valuable Member | Elite Partner

Problem with SSL for primary domain and redirect domain setup

Hi @janz can you check what it shows when you verify the SSL for the redirected .pl domain here:

Jnix284_1-1714001095822.png

 


If my reply answered your question please mark it as a solution to make it easier for others to find.



Jennifer Nixon - Delivery Lead at Aptitude 8

connect with Jen on Linkedin

janz
Participant

Problem with SSL for primary domain and redirect domain setup

Hi @Jnix284 

The screenshot below, that's what I get when I click on Verify SSL for redirected pradzdrewna.pl

pradzdrewnapl_verifyssl.png

Jnix284
Most Valuable Member | Elite Partner
Most Valuable Member | Elite Partner

Problem with SSL for primary domain and redirect domain setup

Hi @janz thanks again, it looks like the HubSpot team is already aware and working on a resolution - tagging in the @CommunityTeam to see if someone can check in on this since the error is persisting.

 


If my reply answered your question please mark it as a solution to make it easier for others to find.



Jennifer Nixon - Delivery Lead at Aptitude 8

connect with Jen on Linkedin

0 Upvotes
Jnix284
Most Valuable Member | Elite Partner
Most Valuable Member | Elite Partner

Problem with SSL for primary domain and redirect domain setup

Hi @janz can you share a screenshot of how you have the two domains configured in HubSpot and share the two URLs, the one you expect is the live/primary domain and the one that should be redirecting?

 


If my reply answered your question please mark it as a solution to make it easier for others to find.



Jennifer Nixon - Delivery Lead at Aptitude 8

connect with Jen on Linkedin

0 Upvotes
janz
Participant

Problem with SSL for primary domain and redirect domain setup

Hi @Jnix284, good to hear from you

I've just had a look again this morning, some strange messages come up, here it goes

Primary domain:

In order, in the first place config for pradzdrewna.com, then pradzdrewna.com and the last screenshot shows the message I'm getting when I click on verify SSL for pradzdrewna.pl. Again, after a few hours when I go to pradzdrewna.pl the SSL seems to work(only the first time. The request must go directly to the server).

pradzdrewna_pl_3.pngpradzdrewna_pl_2.pngpradzdrewna_com_3.pngpradzdrewna_com_2.pngpradzdrewna_com_1.pngSSL_cert for pradzdrewna_pl_verify.png

 

Hope that helps,

Thanks

 

0 Upvotes