Canoncial Tags Set to Http Instead of HTTP

SOLVE
Foxtrot91
Participant

I noticed all of our landing pages are being canonicalized to the HTTP version of the URL instead of HTTPS:// 

For the pages I want in search, is there a way to update this globally across the site in the HubSpot settings? 

or will I have to go through each individual landing page and add in a canonical tag with the HTTPS:// included? 

Thank you in advance for your help! 

SEO
2 Accepted solutions

Accepted Solutions
Foxtrot91
Solution
Participant

Thank you. Users can also update their canonical tag directly at the page level under extra settings. I was looking for a global solution to complete this for hundreds of pages instead of doing it page by page. 

View solution in original post

0 Upvotes
louischausse
Solution
Key Advisor | Platinum Partner

I think I found a solution that will fix this globally. You need to require https in your domain settings:

louischausse_0-1625862991889.png

louischausse_1-1625863008464.png

Don't forget to mark my reply as a solution if you are satisfied. If not, do not hesitate to ask me anything!

 

Louis Chaussé

CEO

Auxilio

lchausse@auxilio.io
auxilio.io
Schedule a call

View solution in original post

11 Replies 11
webdew
Top Contributor | Diamond Partner

Hi @Foxtrot91 ,

Kindly refer this article here.

Hope this helps!

If we were able to answer your query, kindly help the community by marking it as a solution.

Thanks and Regards. 

0 Upvotes
Foxtrot91
Participant

Thank you @webdew Unforatenly, this isn't the solution I'm looking for as our pages are already set to HTTPS:// and it's only the canonical tag that's set to Http:// incorrectly. The Domain Security Settings don't appear to impact the canonical tag (I haven't tested it personally so please correct me if I'm mistaken) 

webdew
Top Contributor | Diamond Partner

Hi @Foxtrot91 ,

So canonical tags simply tell search engines what pages need to be displayed in search results, and so we would want to ensure that it points towards the correct page for visitors. It doesn't seem that they would experience any error per se, just that search engines may not be pulling up the right version of the page for visitors.

To my knowledge, the way that you can ensure the canonical URL is pointing towards the https version of the site, you can consider working with a developer to input the code within the HTML of the page, that would look something like:
<link rel="canonical" href="https//example.com/" />

Hope this helps!
0 Upvotes
Foxtrot91
Solution
Participant

Thank you. Users can also update their canonical tag directly at the page level under extra settings. I was looking for a global solution to complete this for hundreds of pages instead of doing it page by page. 

View solution in original post

0 Upvotes
lcardona
Contributor | Diamond Partner

Hi! We have the same problem, but with the blog and website pages. They are being canonicalized to the HTTP version of the URL instead of HTTPS: //. And it's kind of intermittent. Suddenly it happens for a few minutes and hours and then it goes away. And we have not been able to discover the origin or how to fix it. Have you found the solution in the end?
Have you put on each page manually that the canonical page is the HTTPS version?

Thanks

0 Upvotes
sharonlicari
Community Manager

Hey @lcardona 

 

Welcome to the Community!

 

I've suggested your colleague in this thread reach out to Google's Support team. Also, could you please try what @Foxtrot91 suggested in his last comment? 

 

Thank you

Sharon 


¿Sabías que la Comunidad está disponible en Español?
¡Participa hoy en conversaciones en el idioma de tu preferencia,cambiando el idioma en tus configuraciones!

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
lcardona
Contributor | Diamond Partner

Thank you Sharon! I'll revise this information.

 

 

webdew
Top Contributor | Diamond Partner

Hi @lcardona ,

If this is not working I think the issue may lay with your domain provider. I would suggest reaching out to them and asking why the domain is showing as HTTP when the HTTPS is set as required in Hubspot.I would also ask that if the issue persists that you can share the screenshots and examples to show that the issue is happening intermittently.

Hope this helps!


If we were able to answer your query, kindly help the community by marking it as a solution.

Thanks and Regards.

lcardona
Contributor | Diamond Partner

Thank you! 

0 Upvotes
louischausse
Solution
Key Advisor | Platinum Partner

I think I found a solution that will fix this globally. You need to require https in your domain settings:

louischausse_0-1625862991889.png

louischausse_1-1625863008464.png

Don't forget to mark my reply as a solution if you are satisfied. If not, do not hesitate to ask me anything!

 

Louis Chaussé

CEO

Auxilio

lchausse@auxilio.io
auxilio.io
Schedule a call

View solution in original post

lcardona
Contributor | Diamond Partner

Hi Louis! 

 

Thank you so much for your recommendation. We did it last week and also applied other possible solutions. And for now the error has not been repeated.

 

Thanks.