meetings tool bug: slots available not following start time increment setting

wvk
Participant

I have as settings:

Meetings Tool > Availability >

Buffer time: 15 minutes

Start time increment: 30 minutes

 

When I have no other meetings it shows (as expected) available slots for:

9:00, 9:30, 10:00, 10:30, 11:00, 11:30, 12:00, 12:30, 13:00, 13:30 etc.

 

For a particular day I have one meeting in my calendar: 10:30 - 11:20.

So, the following slots are expected to disappear: 10:00, 10:30, 11:00, 11:30.

 

For that day the meetings tool shows (when booking a 30 min meeting) available slots for:

9:00, 9:30, 11:45, 12:15, 12:45, 13:15, etc.

So, after the existing meeting it jumps to 15 min before and after the hour.

 

The expected behavior is that it shows:

9:00, 9:30, 12:00, 12:30, 13:00, 13:30, etc.

 

0 Upvotes
3 Replies 3
TiphaineCuisset
Community Manager

Hi @wvk 

 

Thank you for reaching out. 

 

I have looked into this and that is expected behavior at this time for the meeting tool. The Meeting tool will optimize for booking as many meetings as possible in the available time period. It will round to the closest 15-minute interval so that the start times are not at odd times.  In your example, with 15 minutes buffer time, the next start time after your booked meeting would be 11:35; so the tool jumps to 11:45 so that it is not an odd start time. 

 

Hope that helps.
Have a lovely day,
Tiphaine.


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
wvk
Participant

Thanks Tiphaine. I understand your point (that it will optimize for booking as many meetings as possible), but if I really want to optimize using the 15 minutes then I can *select* the 15 minute interval. When selecting 30 minute intervals it makes sense that the start times are :00 and :30 throughout the whole day.

0 Upvotes
TiphaineCuisset
Community Manager

Hi @wvk 

 

Thank you for your reply. This is expected behaviour at the moment and the only thing I could think of would be to manually block 25 min after the meeting to make it end at 11:45 so then you have a 15 min buffer time and the next available slot is 12. 

 

I totally understand what you'd want, however, so I'd recommend posting an Idea in our Ideas Forum regarding this. That way other users can upvote it; and the Product Team regularly monitors the Forum

 

Thank you

Best

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes