Your file doesn't have any column headers with an object ID.

ESchmith
Member

Hi I keep getting the same error "Your file doesn't have any column headers with an object ID." when trying to import Deals associated with companies that are already in my Hubspot CRM. I am using the Company ID as the object ID because not all of my companies have domain names. My file definitely does have a column labeled "Company ID" with the associated company IDs downloaded from Hubspot. Why do I keep getting this error anyway?

0 Upvotes
5 Replies 5
warrendavey
Top Contributor | Platinum Partner

@ESchmith - This may sound weird but check for spacing and save your file as a CSV.  Are you importing existing deals? Did you happen to check the Deal ID box too?

If you can send me a screenshot of your headers and the error I can probably help you identify the problem.

✔️ Was I able to help answer your question? Help the community by marking it as a solution.

Davey Waren
Pearagon

Still have questions? Let's Talk

karstenkoehler
Hall of Famer

Hi @ESchmith,

 

Could you share some more detail about your import?

 

Are you importing two files? In that case, your deal file would have to have one column that is shared with the company file (key), the company file would have to include the Company ID previously exported from HubSpot.

 

If you're importing one file (example here), you could omit the key column.

 

Sometimes formatting of the import file can be an issue (an additional empty row above the header, empty rows further down etc.).

 

Could you share a screenshot of the column headers and of the mapping screen during the import process? That would greatly help troubleshoot.

 

Best regards!

Karsten Köhler
Digital Marketer | HubSpot Freelancer | CRM Consultant

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.

ESchmith
Member

The import is one file with multiple objects (Deals and Notes). I have deleted all formatting from the file. I have tried copying and pasting only the cells with data into a new sheet. I've tried both CSV and XLSV files.

 

Here are some images, hopefully that will help clarify things!

 

File upload screen:

Import 1.PNG

Error message:

Error message.PNG

Excel file column headers:

File Headers.PNG

0 Upvotes
ESchmith
Member

I also want to add that I just went through this process and uploaded a small amount of deals with company ID a week or so ago and it worked just fine. I don't see anything different about this file I am trying to import now.

 

And all the company IDs were downloaded from records I already entered into Hubspot.

0 Upvotes
ESchmith
Member

Hi Everyone, I think I figured it out. I wasn't checking the "Company" as part of the upload options in the beginning. Oops! Didn't realize that was needed to be able to make the association. Thanks!