WordPress Elementor Forms not sending to Hubspot CRM

Highlighted
New Contributor

I'm trying everything to get the Elementor Forms (comes with Elementor Pro) to connect and submit form data to HubSpot.

 

Elementor says it's super easy: https://docs.elementor.com/article/262-hubspot 

I can't get it to work.

 

I don't even SEE 'leads' under the Marketing menu...

Reply
0 Upvotes
7 Replies 7
Community Manager

Hi @Strike_Concepts

 

I am not too familiar with Elementor Pro, however the screenshots in the document are outdated. The forms tool now lives under the "marketing" tab from the top navigation.

 

Thank you,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
New Contributor

Curious if this requires a paid version of HubSpot's marketing plan?

Reply
0 Upvotes
Community Manager

Hi @zachsergio,

 

The forms tool is a free tool. 

 

Thanks,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
New Contributor

Hi Jenny, 

I am able to collect form data using Elementor and push it to hubspot on pages that have the elementor form embedded directly on the page, but when I use a form in a popup the data doesn't seem to be collecting. 

Is there any way to test this from your side and see if that is a known error?

Reply
0 Upvotes
Community Manager

Hi @joshvitaldigi,

 

Do you have a link to the page you're working on with the pop up form? 

 

Thank you,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
New Contributor

https://discseel.com/ - Click on Speak to An Expert

https://discseel.com/physicians/ - Or on this page pick any link and then hit send an inquiry. 

It seems like the popup forms aren't capturing properly.

Reply
0 Upvotes
New Contributor

I've spoken to HubSpot about the same issue and had them investigate it. The issue is that that HubSpot will only collect forms that are loaded when the page first loads. It can't see the forms in the popups till they are activated and so it currently doesn't collect the forms that are contained in them. It's an annoying bug.