CRM

MMorissette
Participant

Woocommerce reg form first and last name not showing in Hubspot contact

SOLVE

Hi there,

 

We're facing an issue here with our woocommerce registration form custom input for first and last name not showing in the contact info in Hubspot.

 

We get an error message basically saying that those two values are not properties of Hubspot Contact. 

 

Is there anyway else facing this issue or who knows how to fix this? 

 

Thanks,

 

 

Myriam

0 Upvotes
1 Accepted solution
StjepanGrcic
Solution
Top Contributor | Platinum Partner
Top Contributor | Platinum Partner

Woocommerce reg form first and last name not showing in Hubspot contact

SOLVE

Hi @MMorissette 

 

Please check that the form fields are named and set up like in HubSpot.  You can install HubSpot for WooCommerce plugin to have it everything sync perfectly. 

 

You can also build a From in HubSpot and embed it that way you are sure everything maps out. 

 

Cheers!stjepan_hubspot_forum_footer.png

View solution in original post

StjepanGrcic
Top Contributor | Platinum Partner
Top Contributor | Platinum Partner

Woocommerce reg form first and last name not showing in Hubspot contact

SOLVE

Hi @MMorissette 

 

Click the Settigns Cog - under Data Management click Properties. 

Because these are HubSpot default Contact properties it can't be edited. 

They are named: 

  1. First Name (internal name: firstname)
  2. Last Name (internal name: lastname)

Cheers!

stjepan_hubspot_forum_footer.png

MMorissette
Participant

Woocommerce reg form first and last name not showing in Hubspot contact

SOLVE

Hi @StjepanGrcic  

I'm new in HubSpot, can you tell me where to find the info of how they are named?
Also, since they are important to Woocommerce, I'm want to be sure not to name them differently so that Woocommerce still "understands" them.

 

Thanks!

0 Upvotes
StjepanGrcic
Solution
Top Contributor | Platinum Partner
Top Contributor | Platinum Partner

Woocommerce reg form first and last name not showing in Hubspot contact

SOLVE

Hi @MMorissette 

 

Please check that the form fields are named and set up like in HubSpot.  You can install HubSpot for WooCommerce plugin to have it everything sync perfectly. 

 

You can also build a From in HubSpot and embed it that way you are sure everything maps out. 

 

Cheers!stjepan_hubspot_forum_footer.png