WooCommerce saving country as 2 letter code

Highlighted
Occasional Contributor

I'm trying to set up an integration between my WooCommerce store and Hubspot. So far I've tried using Zapier, Make Web Better (from the Hubspot app marketplace) and Unific.

 

Each time I get an error that basically tells me that WooCommerce has returned a 2 letter code in the country field, that Hubspot does not recognise and therefore won't map.

 

My web developer has suggested I should be able to map the 2 letter codes so they are recognised, but I don't know how to do that. Unific advised that I could change the setting in WooCommerce so it saves the country rather than the 2 letter code - I have no idea how to do that either! Make Web Better have stopped replying...

 

We have a pretty standard WP site and I can't believe I'm the only person to have encountered this issue! Any help would be appreciated!

2 Replies 2
Community Manager

Hi @LVRachel,

 

If you need to create a new custom property in HubSpot to hold this information, you can do so following these steps.

 

Thank you,

Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Occasional Contributor

Thank you Jenny, but it won't help in this case. Both plugins map the country field in WooCommerce to the country field in Hubspot with no option to change it.

 

Make Web Better have now replied to advise that they have fixed the problem, and I can indeed sync customers. However the plugin still doesn't create a new deal, so is really not satisfactory.

 

This whole process seems much more painful than I would have anticipated.

Reply
0 Upvotes