Valid contact not showing up

Highlighted
Occasional Contributor

I have a valid contact that isn't showing up in the HubSpot contact list. I am on the base list with no filters. I can get to the contact by changing the URL to their contact id, but they don't show up in the contact list and I cannot find them when searching. I don't see any property for them that would exclude them. 

Reply
0 Upvotes
9 Replies 9
Regular Advisor

Hey @kaplankada 

 

This is a weird one, are there any special characters you're searching by?  And how are you searching, name or email?

Reply
0 Upvotes
Occasional Contributor

Nope, just searching by name or email. The user was showing up but they managed to create a new contact which I then merged together. Since the merge I haven't been able to find the user using search and they don't show up in lists for which they are eligible.

Reply
0 Upvotes
Top Contributor

@kaplankada 

 

It may have been accidentally deleted.  To find out if this is true, you can navigate to Contacts and then Actions>Restore contacts. This will give you a list of deleted contacts.  If both show up I would restore both and try merging again.  If only one shows up, restore it and see if it contains the information for both records.

 

If it is not in the delete folder and not showing on your list or in search, I am stumped and would recommend submitting a ticket at that point to support who can do a little more research.

Occasional Contributor

I'm not seeing the contact in the recycling bin. 

Reply
0 Upvotes
Top Contributor

At this point, I would re-add them to get them back in your system and submit a ticket. Sorry that it was lost.

Reply
0 Upvotes
Occasional Contributor

So, I ended up adding a new version of the contact and using the API to merge the lost one into the new one. Once I did that the contact started showing up in lists again. Then I did a data import with nearly 200 contacts based on contact id. This contact was in the list. After the import this contact and one other are again in a "hidden" state. I can still get to them by navigating directly to the URL with their ID but cannot find them in search and they aren't in any lists.

Top Contributor

Weird, did you submit a ticket? Seems this would be a great thing for the HubSpot dev team to know.

Reply
0 Upvotes
Occasional Contributor

Yep, I finally ran it through HubSpot support and they were able to fix it. Apparently at some point during a merge the contact id had gotten out of sync with their contact list. 

Reply
0 Upvotes
Esteemed Advisor

@kaplankada This is very odd.  Looks like there is something hidden in their contact on the list to be imported. If you go back and look at all the hidden fields in the CSV, what do you see different from the others?

I would add them back manually and watch it.  Also, I believe someone else mentioned - are there any characters that are the straight letters on the keyboard?  

Reply
0 Upvotes