CRM

DMoreland3
Member

Unable to change Property Visibility

SOLVE

Hello,

 

I am trying to include a custom property on a Meeting form. When editing the property, I am unable to check the box to "Show in forms, pop-up forms, and bots" due to the box being greyed out.

 

2023-10-26_12-25-58.png

 

This is a custom Contact property with the Hubspot user field type. I am a Super Admin. 

 

Any advice on how I can make this property visible in forms? 

 

Thanks in advance,

0 Upvotes
1 Accepted solution
Olivia_Bagnall
Solution
Guide | Platinum Partner
Guide | Platinum Partner

Unable to change Property Visibility

SOLVE

@DMoreland3 Hi again and thank you for coming back to me. 

I just tested on my own portal and also can not set a HubSpot user property to appear on forms. 

The workaround would be to do the following: 

1) Create a dropdown select property with the names of your users and set it to appear on forms. 
2) Create a workflow that triggers when a contact has a known value for this property and then use the wokflow to look at the value and update the user property you have create to the same value. You could do this using an if/then branch followed by the 'set property value' action. 


I hope this helps and please let me know if you have any follow-up questions. Happy to help 🙂 

Olivia Bagnall

Inbound Consultant | HubSpot Specialist | Community Champion

emailAddress
o.bagnall@baskey.eu
website
www.baskeydigital.com
Let's chat
Create Your Own Free Signature

View solution in original post

4 Replies 4
Olivia_Bagnall
Solution
Guide | Platinum Partner
Guide | Platinum Partner

Unable to change Property Visibility

SOLVE

@DMoreland3 Hi again and thank you for coming back to me. 

I just tested on my own portal and also can not set a HubSpot user property to appear on forms. 

The workaround would be to do the following: 

1) Create a dropdown select property with the names of your users and set it to appear on forms. 
2) Create a workflow that triggers when a contact has a known value for this property and then use the wokflow to look at the value and update the user property you have create to the same value. You could do this using an if/then branch followed by the 'set property value' action. 


I hope this helps and please let me know if you have any follow-up questions. Happy to help 🙂 

Olivia Bagnall

Inbound Consultant | HubSpot Specialist | Community Champion

emailAddress
o.bagnall@baskey.eu
website
www.baskeydigital.com
Let's chat
Create Your Own Free Signature
DMoreland3
Member

Unable to change Property Visibility

SOLVE

@Olivia_Bagnall understood. That will do the trick. Thank you for your help!

0 Upvotes
Olivia_Bagnall
Guide | Platinum Partner
Guide | Platinum Partner

Unable to change Property Visibility

SOLVE

@DMoreland3 

Hi there 🙂 My name is Olivia and I am happy to help. 

Unfortunately, once a propery is created with the 'show in forms' box unticked, you can not go back to edit the property and tick it. This setting needs to be set during the property creation process. 

In this case, you will need to clone the property, tick the 'show in forms' box on the clone and then delete the original. 

In this process, you will also nee dto migrate any values for the original property to the new one. 

If you need further information on the best want to clone and replace a property, please let me know 🙂 


Olivia Bagnall

Inbound Consultant | HubSpot Specialist | Community Champion

emailAddress
o.bagnall@baskey.eu
website
www.baskeydigital.com
Let's chat
Create Your Own Free Signature
DMoreland3
Member

Unable to change Property Visibility

SOLVE

@Olivia_Bagnall thank you for the response. I tried cloning the property and creating a new property from scratch, but in both cases the "Property Visibility" box is still greyed out.

DMoreland3_0-1698348763502.png

Is it possible that the "Hubspot user" field type isn't usable on forms?

DMoreland3_1-1698349115578.png

 

 

0 Upvotes