This property is defined by HubSpot and can't be deleted.


I am trying to delete several properties in my "Collected Forms" group but the delete button is dimmed out and gives me the message "This property is defined by HubSpot and can't be deleted." 


These are custom forms that come from my website. Everything was working fine until I needed to edit some of the questions on the form. When I attempted to delete the old questions it gives me the error message above. 


My attempted solutions were: 

1. Export all the contacts and then delete them from Hubspot so there was no occupied fields of data. Nope, that didnt work. 

2. Disable the the forms. Nope, that didnt work either. 


My assumption is that I have to create all the properties FIRST  and then submit the form to hubspot so when it receives the data the properties are already pre-defined and then I can change or edit them. Does that make sense? 


But first, how do I delete these properties. I have over 100 properties in their now because I tried testing with different assumptions and nothing works. Its a mess in there. Please help me delete these. THanks so much. 


PS_ I have exported and deleted all contacts so no property should be in use now. That did not have any impact, still cannot delete custom properties. 

2 Replies 2
Key Advisor

Are the fields you're using custom fields? As in, did you create them yourself? Or are they HubSpot default fields? 


If they're HubSpot default fields, you cannot delete them, hence why you get the message 'This property is defined by HubSpot and can't be deleted' 


If they're custom fields, the best way to delete them would be to use workflows to remove any information from those fields first and then delete the field. You can do this by using the 'Clear contact property value' action.




Did my post help answer your query? Help the Community by marking it as a solution.

Thank you for the reply. Yes these are custom properties -- I created a form on my website with a number of questions and the answers post into my hubspot account. 


I tried your solution but apparently I cannot create a Workflow using a free account. The "Create Workflow" button is dimmed out. 


I had my web developer setup the form on my website and connect it to hubspot. My rationale is that he did not create the properties FIRST in hubspot. He simply set it up to post into hubspot and those properties got locked in. 


At this point I think my only solution is to delete my account and start over? 😕 

Please advise. Thank you kindly.