Stop seeing the "Tracking data is not available" message

RichardG
Contributor

I know that other people have commented on this but this feature is really annoying. We, like others, do not want to track emails sent out to our clients for a multitude of reasons (below copied from another post).

  1. It's distracting and impossible to ignore the little extension icon - oh, who opened my email just now. 
  2. It can affect email deliverablilty, Gmail and Outlook becoming more restrictive to active email accounts over time.
  3. As someone said, we respect our clients and don't need or want to track our clients like that.
  4. It's super annoying and at least there should be a "don't show me this bs again" button

We are aware of this as a conscious decision and do NOT need to be reminded of it on EVERY email. The message is so big that it overtakes the email itself on the initial view. Clearly this is intentional to promote Hubspot's tracking capabilities but surely there is an easy way to remove this in settings? Users are aware of the capability now after seeing it incessantly for 6 months, surely this can be turned off now?

 

This would be a much appreciated development if not already in the pipeline

 

I'm this issue again as it has been marked as an accepted solution but the solution given does not address the core issue of removing the distrcting and annoying message.

 

3 Replies 3
sharonlicari
Community Manager

Hey @RichardG 

 

The message you are seeing cannot be modified. Have you disabled the tracking from within the extension? You can choose not to track the emails either by disabling tracking, changing the setting within the extension, or ensuring each email isn't tracked. 

 

I hope this helps

 

Thank you and Happy Friday!

Sharon


¿Sabías que la Comunidad está disponible en Español?
¡Participa hoy en conversaciones en el idioma de tu preferencia,cambiando el idioma en tus configuraciones!

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
RichardG
Contributor

Sharon

 

Many thanks but the whole point is that we have email tracking turned off within the intergrations settings on our account and on the Outlook extension. So, with tracking disabled we are still getting these messages on our HubSpot. It is very very annoying.

 

I understand the message, we just need to get rid of it

"Tracking data is not available for this email
xxxxxx Support Team chose to log this email but not track it. Learn more"
 
0 Upvotes
Rainer_S
Member

Quick and dirty solution:

 

Block the page element using the browser extension "uBlock Origin", which is available at least for Firefox and Chrome on Windows, using the custom filter "app.hubspot.com##.m-right-4.m-y-2.private-alert--tip.private-alert.alert".

 

Quite easily done with uBlock's built-in element picker.

 

Downsides:

-- It's a per-client setting.

-- Future changes in Hubspot's web interface may require you to tinker with filtering rules (right now they don't break anything).

-- Default rules also filter out Facebook, Google Analytics, and Hubspot's own analytics (fine with me...)