Searching contacts & filtering not working as expected

skynet
Member

In Sales / Contacts when searching with Email / Contains it only works if I include entire string, not a substring of the email field, as expected.

 

That is: searching for "test@test.com" returns the contact with email test@test.com, while searching for "test" returns nothing.

0 Upvotes
8 Replies 8
Phil_Vallender
Most Valuable Member | Elite Partner

Hi @skynet

 

I can confirm that my test CRM is behaving the same way and this is not the behaviour I would expect. As you no doubt know, when you use any of the search bars, you can type just a few letters of a domain and get a result. In the marketing tool, you can build a list using 'email contains [test]' with no problem. 

 

You might have found a bug - perhaps @roisinkirby can help to confirm or correct us?

 

Cheers, Phil.

Phil Vallender | Inbound marketing for B2B technology companies
0 Upvotes
roisinkirby
HubSpot Product Team

Hey @skynet @Phil_Vallender thank you for flagging this!

 

I can't currently reproduce this in my own CRM account, so I'm going to investigate further with our product teams. So that we can troubleshoot further, could you both please send me a private message confirming the HUB IDs of the portals you are seeing this behavior in?

 

Thanks both, I'll keep you posted on this thread 🙂

0 Upvotes
jwright
Participant

I am having the same issue.  It happens sporattically regardless of browser or search field.  Many sales associates have reported a similar issue.  I have created tickets, but have not gotten anywhere.  So far HubSpot does not seem to want to admit that there is an issue.  

Admitedly it's not THAT big of a deal. But it's annoying.  

0 Upvotes
enmelvan
Member

Hi, the problem is still there. Any update on solution? Tnx

0 Upvotes
roisinkirby
HubSpot Product Team

If anyone on this thread is still experiencing this problem, please send me a private message confirming your HUB ID, a gif/video (if possible) of the behavior and confirmations of the term(s) you are searching for and expect to see. Thank you!

0 Upvotes
measuresquare1
Participant

I am trying to use filter to find contacts with email domain names with .au, .uk extensions (instead of .com), Hubspot filter is not matching such contacts.

 

Any tips? Thanks

 

0 Upvotes
Phil_Vallender
Most Valuable Member | Elite Partner

Hi @measuresquare1

 

It think the filter function only kicks in when you have three chars - and this seems to exlude punctuation/symbols.

 

However, it looks like you can overcome this by adding an asterix before .uk. 

 

Searching for *.uk should bring up all contacts with email addresses ending .uk

 

Hope this helps.

Phil Vallender | Inbound marketing for B2B technology companies
0 Upvotes
jeremyjeremy
Member

I am having the same issues but with the new search bar updated MArch 2018

The new search bar is a huge downgrade. Much more difficult to find contacts unless you already have their full credentials. 

0 Upvotes