S L O W loading

SOLVE
gelflex-cc
Recognized Expert

Just wondering if anyone else is experiencing slow loading.  Use Google Chrome browser with Sales Extension.  Each record loads very slowly and seems to show back end items - the domain first pops up "external link" before loading the link. I am not quick enough to get a screenshot. 

 

Also, I typically work on multiple HubSpot tabs at once.  

 

Thanks.

 

1 Accepted solution

Accepted Solutions
jennysowyrda
Solution
Community Manager

Hi all,

 

Is there a specific part of the tool that is slow? Can you confirm the issue is happening across multiple networks and through multiple browsers?

 

If you can share video of what you're seeing, that'd be great!

 

Thanks,
Jenny

View solution in original post

22 Replies 22
rcobbett
Participant

me too, clients are having similar issues also.

jennysowyrda
Solution
Community Manager

Hi all,

 

Is there a specific part of the tool that is slow? Can you confirm the issue is happening across multiple networks and through multiple browsers?

 

If you can share video of what you're seeing, that'd be great!

 

Thanks,
Jenny

View solution in original post

rcobbett
Participant

For me

 

Apple Macbook pro 2019

Latest OS

Chrome - with latest updates as of 9/2/19

Gmail is slow with the addon. Take addon away its fast.

Alon_SA
Participant

Noticing that our HS is running very slow.

We have a bunch of automations + an API connect.

I wonder if this might be causing it. (which it never did in the last 2 years)

 

My whole team – 7 of us, are all experiencing it.

 

Any ideas how to test what could be the cause?

0 Upvotes
jennysowyrda
Community Manager

Hi @Alon_SA,

 

There are many factors that go into the speed, including your internet connection, how many people are drawing on the internet, as well as what browser you are working in.  It's always best to work in the most updated version of your browser.

 

@IsaacTakushi do you have any insight to provide regarding whether APIs can cause delays? 

 

Thank you,
Jenny

0 Upvotes
IsaacTakushi
HubSpot Employee

Thanks for tagging me, @jennysowyrda.

 

It sounds like this thread discusses slow loading in the HubSpot web application (app.hubspot.com). If so, I would not expect the mere use of integrations and the APIs they rely upon to affect app loading times.

Isaac Takushi

Associate Certification Manager
0 Upvotes
janpark
Participant

I also have a problem with a certain team of support agents. Daily the support teams received between 1,000 and 2,000 conversations a day and they've confirmed to become very slow while chatting in conversations and switching between them which affects their productivity and the agents are measured by response time and effectivity in taking the cases. And as you may assume they are significantly bad if the software is slow.


So, in case it's not due to HubSpot limitations, could you please provision specification or minimum requirement of hardware equipment and internet speed and latency, etc?


I'll be in need of those to defend the HubSpot tools to my clients,
And now the agents, many of them are attending from their homes, so even more important.

rowens8
Participant | Diamond Partner

Mine is also really slow - I've turned off all chrome extensions and gmail extensions and identified HubSpot sales as the reason GMail is slow by turning just that back on. 

 

Macbook pro 2020

Latest OS and Chrome version

High Speed internet 25MBps

 

 

JKibler
Participant

Has anyone come up with a fix for the slow loading?  Because I'm finding that HubSpot page loading has been getting slower in the recent weeks.  I typically work in tasks and deals.  I can't tell if one function is slower than others - all seem generally slow.  I have a lot to to and this slow page loading is hampering my productivity.

PamCotton
Community Manager

Hello @JKibler, could you please ensure that you have the most updated version of your browser and your browser cache is cleared? ( more information here). I would also recommend deactivate any extensions in your browser and check if this could help with the slow loading. 

What browser are you currently using? Does this behavior happens in incognito or another browser? 

 

Thank you,

Pam

Você sabia que a Comunidade está disponível em outros idiomas?
Participe de conversas regionais, alterando suas configurações de idioma !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !




0 Upvotes
JKibler
Participant

I'm using Firefox.  I've disabled extensions and tried in private mode.  Still not as fast loading as I'd like.  How long should I expect to wait when clicking open deals?  It can be 2-5 seconds on a regular basis (sometimes longer).  As I jump through a lot of tasks and deals these small lags can really eat into my productivity. 

0 Upvotes
PamCotton
Community Manager

Hello @JKibler thank you for the information provided. Does this behavior occurs when using Chrome also? Users had reported that Chrome is recommended, also as Jenny mentioned on this thread, please confirm if the behavior is happening across multiple networks and through multiple browsers. If you can share a video of what you're seeing, that'd be great!

 

Thank you!

Pam

Você sabia que a Comunidade está disponível em outros idiomas?
Participe de conversas regionais, alterando suas configurações de idioma !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !




JKibler
Participant

You're right, Chrome does seem to be much faster.  Thx

dougfairbro
Participant | Platinum Partner

I've noticed a real drop in speed over the past week or so. I've just upgraded to a brand new MacBook Air, with the latest Google Chrome fresh install.

 

I've turned off all extensions and yet when I load into Hubspot it's excrutiatingly slow. Safari it's fast as anything. On a seperate related note, the HubSpot Sales Extension also slows down my Gmail to the point it won't load properly. Not sure if there was a recent update of Chrome that's caused this.

 

Anyone else having this problem or found a solution?

 

Internet speed test reports 50mb+ during these moments as well. 

 

Thanks!

0 Upvotes
dougfairbro
Participant | Platinum Partner

After a few weeks of testing I think I found the culprite. Norton Anti-virus.

 

We had our security upgraded and ever since installing that onto our devices everything slowed. We've noticed a real jump in speed since removing the software.

 

If you are experiencing slow speeds I suggest checking your browser extensions as sometimes these can cause delays, as well as any VPN or security software.

 

Thanks!

0 Upvotes
karstenkoehler
Most Valuable Member

Hi @dougfairbro,

 

While I don't have a solution, I can confirm it's not just you. I overseeing and managing multiple portals and I'm experiencing the same. @Phil_Vallender @Josh, how about you? Any portals that seem to run slower recently?

 

Best regards

Karsten Köhler
Freelance Digital Marketing Advisor

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.

Josh
Recognized Expert | Platinum Partner

Hi @karstenkoehler ,

 

Sorry for the delayed response. I asked our implementation team and they have not experienced any slowness issues across the different portals.

 

Josh




Did this post help solve your problem? If so, please mark it as a solution.

Josh Curcio

HubSpot support and inbound marketing for OEMs, contract manufacturers, and industrial suppliers.
HubSpot Platinum Partner & HubSpot Certified Trainer

JAviste
Participant

My Contact page loads take just over eleven seconds. Using Chrome, cleared cache, high speed internet, fast computer, only user here in this office and all other websites that I visit are fast performing.

0 Upvotes
PamCotton
Community Manager

Hello @JAviste ,It is best practice to keep your web browsers updated to the latest version to ensure that websites render properly. is your Google Chrome the latest version? To update a supported browser, refer to this documentation here 

 

Thank you,

Pam

Você sabia que a Comunidade está disponível em outros idiomas?
Participe de conversas regionais, alterando suas configurações de idioma !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !




JAviste
Participant
Good thought. I just checked and I have been using the latest version of Google Chrome.
0 Upvotes
ReganB
Participant

We now have this problem as well for our full team. Any ideas? 

0 Upvotes
JAviste
Participant
Try having two computers logged in at the same time. While one is loading, you enter data into the second, then bouncing back and forth, load, enter, load, enter...

Sent from my iPhone
0 Upvotes