S L O W loading

SOLVE
Highlighted
Esteemed Advisor

Just wondering if anyone else is experiencing slow loading.  Use Google Chrome browser with Sales Extension.  Each record loads very slowly and seems to show back end items - the domain first pops up "external link" before loading the link. I am not quick enough to get a screenshot. 

 

Also, I typically work on multiple HubSpot tabs at once.  

 

Thanks.

 

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Community Manager

Hi all,

 

Is there a specific part of the tool that is slow? Can you confirm the issue is happening across multiple networks and through multiple browsers?

 

If you can share video of what you're seeing, that'd be great!

 

Thanks,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
6 Replies 6
Occasional Contributor

me too, clients are having similar issues also.

Community Manager

Hi all,

 

Is there a specific part of the tool that is slow? Can you confirm the issue is happening across multiple networks and through multiple browsers?

 

If you can share video of what you're seeing, that'd be great!

 

Thanks,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Occasional Contributor

For me

 

Apple Macbook pro 2019

Latest OS

Chrome - with latest updates as of 9/2/19

Gmail is slow with the addon. Take addon away its fast.

New Contributor

Noticing that our HS is running very slow.

We have a bunch of automations + an API connect.

I wonder if this might be causing it. (which it never did in the last 2 years)

 

My whole team – 7 of us, are all experiencing it.

 

Any ideas how to test what could be the cause?

Reply
0 Upvotes
Community Manager

Hi @Alon_SA,

 

There are many factors that go into the speed, including your internet connection, how many people are drawing on the internet, as well as what browser you are working in.  It's always best to work in the most updated version of your browser.

 

@IsaacTakushi do you have any insight to provide regarding whether APIs can cause delays? 

 

Thank you,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
HubSpot Moderator

Thanks for tagging me, @jennysowyrda.

 

It sounds like this thread discusses slow loading in the HubSpot web application (app.hubspot.com). If so, I would not expect the mere use of integrations and the APIs they rely upon to affect app loading times.

Isaac Takushi

HubSpot Developer Support
Reply
0 Upvotes