Problems syncing with Boolean SF fields

JPullan
Contributor

I've set up a field 'Is In HubSpot' on HS Companies, so I can see from Salesforce (SF) what Accounts have a corresponding HS Company.

 

Problem I'm having is with the field mapping. The HS field is a checkbox (yes/no) and the SF field is a checkbox (True/False). Having read this page that should be compatible.

 

https://knowledge.hubspot.com/salesforce/map-hubspot-properties-to-salesforce-fields

 

I've set the field mapping to two way, as there is no 'HubSpot preferred' option. However, what's happening is my workflow is updating the value to yes and then SF is overwriting it back to No. Clearly something is going wrong and wondering if anybody else has had this issue with these field types?

 

Is HS Checkbox, not compatible with SF checbox?

4 Replies 4
JessicaH
HubSpot Alumni

Hi @JPullan,


Thanks for reaching out.
I want to tag in some subject matter experts to see if they have any suggestions.
Hi @lynton @Simplii, do you have any thoughts on this?

Thanks!
Jess  


Wusstest du, dass es auch eine DACH-Community gibt?
Nimm an regionalen Unterhaltungen teil, in dem du deine Spracheinstellungen änderst !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
JSG33
Participant

Sad to see no resolution here. Giving this a bump as seeing this issue still in 2021.

0 Upvotes
JPullan
Contributor

@JSG3 , I did get this working with HubSpot Support's help in the end. Unfortuanately the ticket history was lost due to an error with HubSpot's Support live chat, but did manage to salvage this. 

 

'

In our mappings, the salesforce property is a pickList and the HubSpot property is a single checkbox. According to this article, it should be mapped to a Hubspot boolean property. This is likely the issue that is causing the overwrite. Please try changing the property to appropriate types as highlighted in the article mentioned above.

'

 

From what I can remember the field mapping was the issue

0 Upvotes
JSG33
Participant

Thanks @JPullan! What is odd is I believe we are setup in the optimal format as HS has recommended here (single checkbox to boolean) and we're seeing this come up on these fields syncing. We're weighing if it would be better to switch to picklists rather than the current checkbox setup. We'll see what HS support says - appreciate the response!

0 Upvotes