New Contacts with emails creating NEW Companies even though Domains are the same

dhartzer
Member

We are having an issue with HS creating a NEW company when we enter a new contact even though the domains match in the company domain and the contact email. Why is this happening? It is causing our database to get junked up and then when we go to the company, it appears our contact hasn't been entered. 

 

Also, it would be great if we could enter a new contact from the association button in other contacts. For instance, I get an email from Suzy and want to associate to someone she copied on the email but is not entered in HS. So, then I have to go out to create the new contact and remember to go back to link the email to the new contact. Time consuming. 

0 Upvotes
1 Reply 1
webdew
Top Contributor | Diamond Partner

Hi @dhartzer ,

If the domain are matching then no way the new company should be created but associate the new contact with the existing company. Might be a bug. There is no way I can check it your portal so will advise you to connect with HS support by clicking the blue button at the bottam right sid eof your account. Give them an example of the contact and company. they will be able to check at the backend for you.

In your second query, I belive you want to associate a contact with a contact? This is not possible currently but you can check this idea submitted by a user for the same issue. Please upvote it. HubSpot product team review these ideas and work on them.

Hope this helps!


If we were able to answer your query, kindly help the community by marking it as a solution.

Thanks and Regard.

0 Upvotes