Job Title field is adding the word "job" in front of the imported title

SOLVE
Occasional Contributor

For the past 3-4 weeks Hubspot has been adding the word "job" in front of contacts I create manually, ones I respond to via email, as well as 9000+ that I imported.

Contact.png

 

 

This one (top) was an email I responded to.

 

 

 

 

 

 

Contact 2.png

 

This was from a CSV import.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Top Advisor

Thanks, @Shannyn. The integration change source on all those shots make it look like it's something external that's doing this. Next steps are to review integrations which could conceivably touch all these contacts, and troubleshoot there to see if there's logic or automation set up doing this. 

 

Depending on how many integrations you have connected, and whether they're custom-built ones versus standard ones (either supported by HubSpot or a third-party). 

 

Go to your integrations page within your portal (available by clicking the drop-down where your info appears at the right of the top nav bar, then choosing Integrations), and review any integrations which could potentially be in play. It looks like this is something which fired shortly after the creation via import, on contacts. That may rule out some integrations immediately.

 

Based on the volume of records which are impacted, and the speed with which those updates were made, I'd guess it could be something Zapier or the Salesforce connector is doing; it may also be something custom-built by your org. 

Reply
0 Upvotes
7 Replies
Top Advisor

Hi, @Shannyn. Something like this looks like an import, workflow, or integration may have been the culprit. We'll need to work backwards to figure out what happened. 

 

Click any of those contacts which are impacted, and view their property history. Do a search for "Job title", and you'll see all values that property has ever had in the history. The history will show you which user made the change, and when, and what the change source was. 

 

That last bit, the change source, can identify how the value was changed to the undesired value. Spot-check a few contacts - is the change source common to these values something like "IMPORT" or "Workflow" or a third-party integration? Or does it list the username of a user in your portal instead? 

Occasional Contributor

Hey @bmampe,

 

So I looked into three, here's what it shows, it says Integration for all 3:Contact 3.png

 

Imported contact

 

 

 

 

 

 

 

 

Contact 5.png

 

Contact created by responding to an email from them

 

 

 

 

 

 

 

Contact 5.png

 

Contact created by them filling out my form on my website

 

 

 

 

 

 

 

 

Top Advisor

Thanks, @Shannyn. The integration change source on all those shots make it look like it's something external that's doing this. Next steps are to review integrations which could conceivably touch all these contacts, and troubleshoot there to see if there's logic or automation set up doing this. 

 

Depending on how many integrations you have connected, and whether they're custom-built ones versus standard ones (either supported by HubSpot or a third-party). 

 

Go to your integrations page within your portal (available by clicking the drop-down where your info appears at the right of the top nav bar, then choosing Integrations), and review any integrations which could potentially be in play. It looks like this is something which fired shortly after the creation via import, on contacts. That may rule out some integrations immediately.

 

Based on the volume of records which are impacted, and the speed with which those updates were made, I'd guess it could be something Zapier or the Salesforce connector is doing; it may also be something custom-built by your org. 

Reply
0 Upvotes
Occasional Contributor

Thanks @bmampe,

 

Being that this CRM is so new, there's very few integrations, thank goodness. I suspect it's Automate.io, have you hard any feedback in the community about this?

Integrations.png

 

 

Top Advisor

I know of automate.io, but haven't used it. It's not dissimilar from how Zapier works, however. If you don't have automate credentials, find someone on the team who does, and see what pices of automation are attempting to do something with the job title field. There's something active there which is adding the undesired value (or adding it to an undesirable amount of contacts). 

 

[If the undesired behavior has stopped, you may want to look through any deactivated automation which may have acted unexpectedly on this property in the past. That won't fix the data, but it may not necessarily be active automation which impacted the data previously.]

Occasional Contributor

Hi @bmampe,

 

I am the team lol.

 

I disabled the application, exported the contacts, fixed the Job Title field and imported them back in with their ID's. It took multiple attempts to get it right but it's majoritally fixed for now.

 

Thanks for your help!

Highlighted
Top Advisor

Glad you got it resolved. I'm not totally sure what happened here, but I would not expect that error to persist after your efforts.