Importing contacts with companies no domain name

SOLVE
Highlighted
New Contributor

I am importing a list of SMALL companies they do not have a domain name. Many of these owners are using gmail and hotmail accounts.  As I started the import, i got a notice that each line will be a record.

 

Is there a way to import contacts with companies in this circumstance?

 

Thanks in advance

Reply
0 Upvotes
2 Accepted solutions

Accepted Solutions
Highlighted
Regular Contributor | Diamond Partner

Hey,

 

Contact and companies are different record types, so if you want to import contacts and associate them to a company at the same time you need to do a multiple object import. On this page go to the section which says "Contacts and companies sample spreadsheet" and you can download an example of how to upload the data so it works for you:
https://knowledge.hubspot.com/crm-setup/set-up-your-import-file



----------------------

Did my post help answer your query? Help the Community by marking it as a solution.


Full HubSpot agency: https://www.digital22.com/


One off HubSpot tasks: https://www.hubsprints.com/

Highlighted
Regular Contributor | Gold Partner

Hi.

 

So it sounds like 2 things are going on so I'll break them down and respond to each separately:

 

1. Message/Notification about not able to upload Companies in General:

Like HubSpot uses email as the unique identifier when adding Contacts to to your portal, for Companies, it uses domain name. 

 

If you were to upload a list of Contacts without email address, you would get the same notification, that each line would be a new record. This helps eliminate potential duplicates in your portal if it can verify that it is indeed the same record being updated, not added.

 

You do need at least Company Name OR domain name to upload a new Company record. If you are just updating Company Records you already have in HubSpot, you can use the Company ID, and then you avoid all of the above.

 

2. Associating Contact to Companies During Import:

Without seeing the whole error/warning or your spreadsheet headers, it appears you might be missing the "Common Field" Identifier that matches the Contact to the Company Record. This is explained in the link that was shared previously: https://knowledge.hubspot.com/crm-setup/set-up-your-import-file

 

Something else to consider: the setting on Companies that Automatically create/associate companies with contacts requires use of the contact's email address and company's doman to make the association. You can turn this off, if you are going to associate the conacts to the companies later, when you add in the domains.

Settings > Contacts & Companies > Companies:Screen Shot 2020-06-30 at 10.56.54 AM.png

 

Hope that helps a bit!

√ Did my post help answer your question? Pay it forward and help the Community by marking it as solution!
Reply
0 Upvotes
21 Replies 21
Highlighted
Regular Contributor | Diamond Partner

Hey,

 

Contact and companies are different record types, so if you want to import contacts and associate them to a company at the same time you need to do a multiple object import. On this page go to the section which says "Contacts and companies sample spreadsheet" and you can download an example of how to upload the data so it works for you:
https://knowledge.hubspot.com/crm-setup/set-up-your-import-file



----------------------

Did my post help answer your query? Help the Community by marking it as a solution.


Full HubSpot agency: https://www.digital22.com/


One off HubSpot tasks: https://www.hubsprints.com/

Highlighted
New Contributor

Thank you

I looked at the spread sheet samples you sent and This is the way mine are set up. Same line hold record "company" and "Conatact"   If I understand you they will be pulledinto hubspot and if I look up the contact it will be associated with the company. Is  that right?

 

Thank youin advance

Reply
0 Upvotes
Highlighted
Regular Contributor | Diamond Partner
Exactly right! 👍


----------------------

Did my post help answer your query? Help the Community by marking it as a solution.


Full HubSpot agency: https://www.digital22.com/


One off HubSpot tasks: https://www.hubsprints.com/

Reply
0 Upvotes
Highlighted
New Contributor

yes

Reply
0 Upvotes
Highlighted
New Contributor

This is not working see message

 

hubspot import.jpg

Reply
0 Upvotes
Highlighted
Regular Contributor | Diamond Partner

Hmmmm.... can't say I've come across this as I have only worked with companies with a domain. This may not be great but to get the job done you could also use a 'dummy' domain eg www.<clientname>-<yourcompanyname>.com ?



----------------------

Did my post help answer your query? Help the Community by marking it as a solution.


Full HubSpot agency: https://www.digital22.com/


One off HubSpot tasks: https://www.hubsprints.com/

Reply
0 Upvotes
Highlighted
New Contributor

Are yoou suggesting manually moving into each account and creating a dummy domain? Hub spot must not be designed for people selling to small businesses.

 

Thank you

Reply
0 Upvotes
Highlighted
Regular Contributor | Diamond Partner
You could do it in the import file rather than manually.

We work with many clients selling to small business and B2C. The difference here is the need for company records and doing this through an import whilst not having a domain to keep them unique. In the industries we have worked in even the smallest of business (1 person) have a domain. I'm not saying that's correct of all industries but I don't personally have the experience in setting up HubSpot this way. My way would work but it would be a workaround so perhaps there is a better solution.


----------------------

Did my post help answer your query? Help the Community by marking it as a solution.


Full HubSpot agency: https://www.digital22.com/


One off HubSpot tasks: https://www.hubsprints.com/

Reply
0 Upvotes
Highlighted
New Contributor

Thank you I appreciate your help and please do not feel i was diminishing your support. I know you are here to help.

 

What I think you suggested was to go into ech account manuualy and create a Dummy domain to tie the accounts together. Did I read that correctly. 

 

if so I can see a path forward with my VA.

 

Thanks again for your help.

Reply
0 Upvotes
Highlighted
Regular Contributor | Diamond Partner
No not at all. I'm just sorry there isn't a straight forward solution.

What I was suggesting was going back to the import spreadsheet and putting the unique dunmy domain in there so your import won't get the same errors as above.


----------------------

Did my post help answer your query? Help the Community by marking it as a solution.


Full HubSpot agency: https://www.digital22.com/


One off HubSpot tasks: https://www.hubsprints.com/

Reply
0 Upvotes
Highlighted
New Contributor

OK I tried a test. 

 

8 acompanies and contacts. I added a column to the spread sheet "dummy Domain" I copied the commpany name into that field to "tie" accounts. They did not load. The Error code is "INVALID_ALTERNATE_ID" 

 

Seems I am missing something. Any ideas?

 

Thanks

Reply
0 Upvotes
Highlighted
Regular Contributor | Diamond Partner
Was it in domain name format? Eg www.company.com


----------------------

Did my post help answer your query? Help the Community by marking it as a solution.


Full HubSpot agency: https://www.digital22.com/


One off HubSpot tasks: https://www.hubsprints.com/

Reply
0 Upvotes
Highlighted
New Contributor

No it was not. I am trying to find a way to import very small businesses. (400K 0 1.5 Million. Many still use yahoo and gmail accounts.

 

I would like to import versus input one at at time. Is there an alternate way to tie companies to contacts?

 

Reply
0 Upvotes
Highlighted
Regular Contributor | Gold Partner

Hi.

 

So it sounds like 2 things are going on so I'll break them down and respond to each separately:

 

1. Message/Notification about not able to upload Companies in General:

Like HubSpot uses email as the unique identifier when adding Contacts to to your portal, for Companies, it uses domain name. 

 

If you were to upload a list of Contacts without email address, you would get the same notification, that each line would be a new record. This helps eliminate potential duplicates in your portal if it can verify that it is indeed the same record being updated, not added.

 

You do need at least Company Name OR domain name to upload a new Company record. If you are just updating Company Records you already have in HubSpot, you can use the Company ID, and then you avoid all of the above.

 

2. Associating Contact to Companies During Import:

Without seeing the whole error/warning or your spreadsheet headers, it appears you might be missing the "Common Field" Identifier that matches the Contact to the Company Record. This is explained in the link that was shared previously: https://knowledge.hubspot.com/crm-setup/set-up-your-import-file

 

Something else to consider: the setting on Companies that Automatically create/associate companies with contacts requires use of the contact's email address and company's doman to make the association. You can turn this off, if you are going to associate the conacts to the companies later, when you add in the domains.

Settings > Contacts & Companies > Companies:Screen Shot 2020-06-30 at 10.56.54 AM.png

 

Hope that helps a bit!

√ Did my post help answer your question? Pay it forward and help the Community by marking it as solution!
Reply
0 Upvotes
Highlighted
New Contributor

OK Something seems lost in translation

1. I am importing one  sheet two bijects (contacts and Companies)

2. I am mapping as prescribed by system

3. Many of these individuals DO Not have a coomon company domain. They are using yahoo, msn, aol etc.

4.  I Am following the SMAPLE SPread sheets you so kindly sent me again the diffference again is no common domain name.

5. I did try to use a dummy domain utilizing the  company's name in an attempt to get them to tie.

6. I am attaching a picture of the format of my file.Hubspot test fail.jpg

Reply
0 Upvotes
Highlighted
New Contributor

Thank you for your reply. THis is what I am doing 1 file - multiple objects - contacts and companies. I tried setting up dummy domain (not a .com or .net extentions) just a cut and paste of teh company name in hopes of creating an id that would tie the files... no luck so far

Reply
0 Upvotes
Highlighted
Regular Contributor | Gold Partner

Ok, without seeing your error files this is what I did to see if it helps:

  1. Turned off "Automatically create & associate companies with contacts" in settings.
  2. Created Test Company & Test Contact Spreadsheets. The common field is just a string of numbers/letters YOU make up and say this string "ABC123" on this company goes with this specific contact record (or vice versa). As long as it is unique for each company, you should be fine.
    CompanyCompanyContactContact
  3. Imported associated objects
    Screen Shot 2020-07-01 at 10.39.44 AM.pngScreen Shot 2020-07-01 at 10.40.00 AM.png
  4. Mapped the columns on both docs:
    CompanyCompany   ContactContact
  5. Completed the import and checked for errors in the error logs: Screen Shot 2020-07-01 at 10.43.09 AM.png
  6. Verified that the Contacts & Companies Loaded into the Portal:
    CompanyCompany ContactContact

As you can see in the error log and the display in the portal, the only company that didn't import was the one with the incorrect domain name and its respective contact record (because I told the system to associate it with a company it couldn't import.

 

If I went back and corrected/wiped out the domain name on Company Test2IncorrectDomainFormat and reimported the associated contact as well, they will be uploaded.

 

I would say, check to make sure your files look like step 2, and then look at your error logs, they will tell you exactly what is incorrect on your upload files.

√ Did my post help answer your question? Pay it forward and help the Community by marking it as solution!
Reply
0 Upvotes
Highlighted
New Contributor

Hi I tried what you suggested.

 

I turned off the automatically associate.

I added a common field

When I added the import field I did not get presented a choce on how to "associate' The files. (I believe this was your step 3.

 

I should also point out I am using a ree version of hubspot

 

Reply
0 Upvotes
Highlighted
Regular Contributor | Gold Partner

Your version of HubSpot shouldn't matter, so that's a good thing.

 

It looks/sounds like the dummy domain is what is causing the biggest issue. If you are going to put something in there, it HAS to have a .com/.net/."somethingvalid" EVEN if the domain doesnt exist. I'd suggest NOTHING, rather than have potential errors on the import (delete column P). The worst thing that will happen is you could potentially have duplicate companies, which you can easily merge.

 

In my example, the ONLY company domain that doesn't import is the incorrectly formatted one. From what I can see on your file, you have 2 - K & P (if you are using website from Column K for the company url). Column P in yours is formatted like the 2nd one in my example and why it is not importing:

Screen Shot 2020-07-06 at 10.28.13 AM.png

 

Since you are using a single file, the association part is slightly different.

 

Import > Start an Import > File from computer > Next > One File > Next > Multiple objects > Next > Companies AND Contacts > Next > Upload files >  Map Column Headers 

 

In this case (1 file import) you will NOT use the common field column.

 

If you use a single file, you will need to have 2 Columns for properties like: Company Name (1 to associate to the Contact Object = Company Name and the other to associate to the Company Object = Company Name) 

 

I outlined the properties/columns I am assuming you have for both Companies & Contacts in your example file. In this case the association is done when you are mapping the columns. So you just have to be careful what you are choosing when you are mapping the properties, that you select the right object. The system will make its best guess, but you need to double check it has chosen the right HubSpot Property that matches your data:

Hubspot test fail.jpg

 

As long as you change the format of your dummy domain and choose the right object when you are importing the properties, that should resolve your issue. If you are still getting issues, please post your error file...that will tell us what the system is saying is wrong.

√ Did my post help answer your question? Pay it forward and help the Community by marking it as solution!
Reply
0 Upvotes
Highlighted
New Contributor

OK This is getting closer I think.

 

Attached is the error Message

 

Also the mapping I have done.

 

Because not all of the companies have websites I wonder if I can use "Name" as a property. If so I don't see how to do that.

 

I do appreciate all your help. Hub spot Mapping.jpgNo Unique Identifier.jpg

Reply
0 Upvotes
Highlighted
Regular Contributor | Gold Partner

Ok, the pink error is what I was referencing in my last reply for "Company Name" needing to be duplicated for both Contact & Company Objects. You currently have it mapped to the Contact Object now, which works, you just have to do one more step:

Hub spot Mapping.jpg

You can tell what type of HubSpot property you are mapping to by the icon next to the property name (pink = company icon/property selected; green = contact icon/property selected).

 

So if you duplicate column A in your spreadsheet and call it "Name" then map it to the Company "Name" HubSpot property you should be good to go.

√ Did my post help answer your question? Pay it forward and help the Community by marking it as solution!
Reply
0 Upvotes