Import error: Can't process number '#####' because it is too big (or too small)

chrispower
Participant

I'm attempting to import a file to update the value of a contact property for a set of contacts.  The file contains the 'Contact ID', and a column containing the property value to be updated.

 

The property being updated is an 'Unformatted number'.

 

To date, this property has been set either via a form, or directly in the contact UI, with no issues.  

 

The values being set for the property are 22 digit numbers which look like this: '0500191111111001110785'.  

 

The import process is returning this error for every record in the file:

Can't process number '0500191111111001110785' (from column 'property_name') because it is too big (or too small)

However I can successfully set the same value via a form or in the contact UI.

 

It appears that some kind of validation is being applied to the value during the import, however I can't see what this validation is, or if it is configurable.  I also don't understand why the import would apply validation that doesn't exist anywhere else, and prevent me from entering what is otherwise a perfectly valid value for this property.

 

 

0 Upvotes
2 Replies 2
sharonlicari
Community Manager

Hey @chrispower 

 

Apologies for the delay answer, I am wondering if you still having this problem. If so, I would suggest reviewing this article from our KB where explains how to troubleshoot import errors.

 

I hope this helps

 

Thanks

Sharon


¿Sabías que la Comunidad está disponible en Español?
¡Participa hoy en conversaciones en el idioma de tu preferencia,cambiando el idioma en tus configuraciones!

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
chrispower
Participant

Hi Sharon

 

Yes, the problem still occurs.  I had already seen the article you linked to, but it doesn't address the error we're seeing.

 

I've worked around it by changing the property type to text (which in itself was very complicated), but the issue is still present.  If I enter a particular value via a form, or directly in the Contact UI, it works.  If I enter the same value in the same field via an import, it fails.  This creates a really inconsistent experience.  If the same error had occurred when using forms or the UI, we would have picked it up early and changed the property type then.  As it is, we didn't notice this until we had a requirement to do an import, and by that time, the field was populated for hundreds of contacts, and in use in multiple forms and workflows, making it very difficult to change.

 

Thanks 

0 Upvotes