Hubspot not registering conversions from Facebook

RaimundoEstela
Participant

Good day Hubspot Community!

 

We've been using Hubspot for 10 months without any problem, it all works great, but there's a single instance where it doesn't seem to work: Facebook conversions.

 

Whenever we set up an ad campaign in Facebook suite, Hubspot recognizes the ads, lists them in Marketing > Ads, but for some reason, after an initial succesful run, it stopped detecting conversions at all around on march. We have a Page View conversion event set up on Facebook on our thank you page, same as we used to, and we haven't changed it. Same thank you page, same forms.

 

At first we thought there weren't conversions at all, since we've been focusing mainly on GAds, but after a while, we started noticing a lot of "False positives" detected by Facebook on their Ads Manager, meaning Facebook could read conversions from their manager (Specific from a campaign, not in their event manager which shows conversions from all sources), but Hubspot didn't show any "Paid Social" conversions at all. 

 

 This month, we started a huge campaign, with great interaction and click results, but we still had no conversions, even if Hubspot did detect the Ads running. I made a test and,  for some reason, Facebook conversions aren't being registered at all. Instead, Source 1 is being listed as my Form link, there is no Source 2, and Source Origin is listed as Direct Traffic.

 

I checked everything, from proper Pixel integration, manual UTMs, and coding, but I couldn't find anything wrong. 

 

Is there anything else I should check? If not, have you experienced this kind of problems and know any way to solve it?

 

Thanks in advance, 

Ads
6 Replies 6
TiphaineCuisset
Community Manager

Hi @RaimundoEstela 

 

Thank you for reaching out.

 

I want to tag some of our experts on this - @DavidDennison @NicoleSengers @Jonno_Price do you know what could be happening here? 

 

Thank you!

Best

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


Jonno_Price
Top Contributor | Platinum Partner

Hi @RaimundoEstela 

 

It's hard to know for certain without checking all settings - but one thing I noticed is that it is best not to use UTMs in the destination urls when building the ads in FB campaign manager. Instead use the plain destination url and allow the HubSpot <> Facebook integration to create the tracking parameters automatically. 

Similarly you need to ensure pixel is on and being injected via the HubSpot javascript and that the HubSpot JS is published and active on the page where the leads are being collected. If the ad is a lead gen ad format then you must also ensure that lead syncing is turned on. 

Hope that helps as a starting point. 

================
Jonno Price
Growth London Ltd.
Platinum Hubspot Solutions Partner
RaimundoEstela
Participant

Thank you Jonno. (And thanks for all the other times you've helped me answering other people's questions in this forum)

 

Hubspot's javascript and json are on and lead collection is on, since we use the same form for our Google Ads campaign, which is succesfully registering leads and assigning them as Paid Search leads

 

EDIT: I've got something extra. After editing my final link directly to my form, Hubspot was able to detect conversions without any problem. However, if I return them to my original link, which was my landing page, it doesn't work anymore. 

Google seems to be able to track this double click, however, Facebook loses tracking entirely.

 

I have no idea what is wrong, is there something else you might need in order to find what might be wrong?

 

Thank you so much for your help in advance 🙂 

DavidDennison
Key Advisor

Have you set up the Fb Conversion API? Also, make sure that you have aggregated events set up correctly as well. Seems like there is a communication error, and knowing FB, it's probably on their end.

twitter
linkedin

David Dennison

Social Media, Content,

and SEO Marketing

7025565062
david@daviddennison.com
https://www.k2analytics.com
RaimundoEstela
Participant

Hi! Thanks for your quick answer.

 

I've set up the Conversion API, and I know it works because Facebook can track the conversions, it's just that they don't appear in my HubSpot contact list with "Paid Social" as it source and without Facebook Click ID.

 

What's weird, and what I think might be the issue, is that if I link my Ads directly to my form, both HubSpot and Facebook detect them. If I leave my Landing as destination (like it is set up atm), whenever my prospects click to go to the form Facebook stops tracking and detects them as Direct Traffic with my landing as source 1.

DavidDennison
Key Advisor

Definitely a strange case but without getting deeper into it, I would say it's something along those lines. I'll see if I can do some more research and get a more slid answer for you!

twitter
linkedin

David Dennison

Social Media, Content,

and SEO Marketing

7025565062
david@daviddennison.com
https://www.k2analytics.com