CRM

Bondford
Member

Google Ad Not Appearing

SOLVE

In my ads, I only see my LinkedIn advertisement. 

 

I have changed my Google Ad account to expert mode from smart mode. 

 

Hubspot Support.JPG

0 Upvotes
1 Accepted solution
JenBerenguer
Solution
HubSpot Employee
HubSpot Employee

Google Ad Not Appearing

SOLVE

Hi Daniel, I was investigating a similar issue to yours that was resolved through the following steps:

 

There are a few things to check prior to this which also include permissioning issues with the account. Could you run through the steps as per this documentation here to ensure that you have the relevant permissions in Google ads, i.e.

  • The HubSpot user who connects a Google Ads account must have Admin access for that individual account. In your Google Ads account, you can check the access level for any user by clicking the Tools dropdown menu and selecting Account access.

In addition to that

  • HubSpot is not able to track or report on Smart Campaigns (formerly Google Express Campaigns). If you've recently created your Google Ads account, it will be in Smart Mode by default. While in Smart Mode, all ads will be created as Smart Campaigns. Could you check if your account is in Smart Mode:
    • Log in to your Google Ads account.
    • If the URL begins with ads.google.com/aw/express, then your account is in Smart Mode.
    • To switch to Expert Mode, click Tools in the top menu, then select Switch to Expert Mode

 If you are still not able to view this, there's this documentation here on a post to switch to expert mode.

 

Let me know if that helps.

Jen

View solution in original post

0 Upvotes
5 Replies 5
Bryantworks
Key Advisor

Google Ad Not Appearing

SOLVE

Hey @Bondford,

 

Are you showing all accounts in the filters?

 

Ads _ HubSpot - Google Chrome 2019-07-15 08.20.23.png

Chris Bryant | Your Dedicated HubSpot Expert
DnielCoelho
Member

Google Ad Not Appearing

SOLVE

Hi, Im having the same issue. And both accounts are checked in the filter. Can someone help me, please.

 

Thanks!

 

Tried so far:
• Disconected the Google Ads account and then conected again.
• Turned off and then on the auto tracking.
• Revoke hubspot access for this account and then granted again

 

Screenshot_1381.png

0 Upvotes
JenBerenguer
Solution
HubSpot Employee
HubSpot Employee

Google Ad Not Appearing

SOLVE

Hi Daniel, I was investigating a similar issue to yours that was resolved through the following steps:

 

There are a few things to check prior to this which also include permissioning issues with the account. Could you run through the steps as per this documentation here to ensure that you have the relevant permissions in Google ads, i.e.

  • The HubSpot user who connects a Google Ads account must have Admin access for that individual account. In your Google Ads account, you can check the access level for any user by clicking the Tools dropdown menu and selecting Account access.

In addition to that

  • HubSpot is not able to track or report on Smart Campaigns (formerly Google Express Campaigns). If you've recently created your Google Ads account, it will be in Smart Mode by default. While in Smart Mode, all ads will be created as Smart Campaigns. Could you check if your account is in Smart Mode:
    • Log in to your Google Ads account.
    • If the URL begins with ads.google.com/aw/express, then your account is in Smart Mode.
    • To switch to Expert Mode, click Tools in the top menu, then select Switch to Expert Mode

 If you are still not able to view this, there's this documentation here on a post to switch to expert mode.

 

Let me know if that helps.

Jen

0 Upvotes
DnielCoelho
Member

Google Ad Not Appearing

SOLVE

Hi, Jen. Did both steps and now it's working. Thank you so much.

JenBerenguer
HubSpot Employee
HubSpot Employee

Google Ad Not Appearing

SOLVE

Happy to hear , @DnielCoelho 🙂

Do you mind accepting it as a solution?

Best,

Jen