Emails aren't going into hubspot

SOLVE
ZMandel
Member

I've been using Hubspot for about a year.  We have an email setup whereby any emails sent to that address are brought into hubspot, by hubspot.  It has been working perfectly until the past few days.  Lately, some (not all) emails that are received in my inbox do not get processed into Hubspot for many hours, while some get processed right away.  I'm now concerned that emails are getting lost.  What can I check, what can I change, who can I speak with?

 

Thank you

CRM
0 Upvotes
1 Accepted solution

Accepted Solutions
StefaniUAT
Solution
Key Advisor

Hi @ZMandel,

I have experienced a similar situation. It is annoying but in my particular situation it was completely technical/backend based. I will do my best to break down my specific situation in the case that it helps. HubSpot accounts allow for a particular amount of API calls and then those API calls are subject to the current server needs. AKA each time something needs to be processed on the backend, especially from an integration, it has to go through protocols that's speed is subject to the current availability of the account, API calls, server, third-party server, etc.  If the information takes a while to process but still processes, it likely means there is a holdup on the backend. There are things you can do to relieve this but it doesn't necessarily mean the information is lost. A lot of times, this is normal and temporary. However, auditing is always the correct next step.

 

For auditing, your best bet is directly comparing emails sent to those that are tracked in HubSpot after 24 hours. Do what you can to track emails sent on your end and then pull lists/reports to cross-reference.

 

If you have more than a free "prescription" you can ask Live Chat support efficiently. Phone or email support is also helpful, just not as quick. 

Best,
Stefani Johnson
Defect and Database Administrator
University of Advancing Technology
uat.edu I Earn Tech Respect

View solution in original post

1 Reply 1
StefaniUAT
Solution
Key Advisor

Hi @ZMandel,

I have experienced a similar situation. It is annoying but in my particular situation it was completely technical/backend based. I will do my best to break down my specific situation in the case that it helps. HubSpot accounts allow for a particular amount of API calls and then those API calls are subject to the current server needs. AKA each time something needs to be processed on the backend, especially from an integration, it has to go through protocols that's speed is subject to the current availability of the account, API calls, server, third-party server, etc.  If the information takes a while to process but still processes, it likely means there is a holdup on the backend. There are things you can do to relieve this but it doesn't necessarily mean the information is lost. A lot of times, this is normal and temporary. However, auditing is always the correct next step.

 

For auditing, your best bet is directly comparing emails sent to those that are tracked in HubSpot after 24 hours. Do what you can to track emails sent on your end and then pull lists/reports to cross-reference.

 

If you have more than a free "prescription" you can ask Live Chat support efficiently. Phone or email support is also helpful, just not as quick. 

Best,
Stefani Johnson
Defect and Database Administrator
University of Advancing Technology
uat.edu I Earn Tech Respect

View solution in original post