Email responses not being delivered - SMTP error

Highlighted
New Contributor

Hi there

 

I've been testing sending/recieving emails from the CRM, from both the Deals page and from the Conversations inbox channel.

 

When an email is responded to by the user, it's recieved in my mailserver at our domain but NOT in the CRM.

 

This is the scenario:

1) User "X" sends an email to our mailserver - it is recieved in the mailserver and in the CRM.

2) We respond to it via either the Communications inbox channel or from the Deal page in the CRM - user "X" recievies the email, we have a copy in the inbox channel or in the Deal page (and in our mailserver if from Deal page).

3) User "X" then responds to that email - it is recieved in the mailserver but NOT in the CRM. User "X" recieves a 'Mail Delivery System failed' email that say:

 

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

[hubspot email forwarding address]

  (ultimately generated from accounts@mydomain)
   host smtp.antispamcloud.com [38.111.198.189]
   SMTP error from remote mail server after end of data:
   550 Headers contain illegal BOM
Reporting-MTA: dns; hp296.hostpapa.com

Action: failed
Final-Recipient: rfc822;accounts@mydomain.com
Status: 5.0.0
Remote-MTA: dns; smtp.antispamcloud.com
Diagnostic-Code: smtp; 550 Headers contain illegal BOM

 

I am using the free hubspot CRM.

I have turned off tracking in emails.

I have spent hours researching and trying to fix this, but am yet to find a solution.

 

Is there anyone that can help?

Thanks

 

Reply
0 Upvotes
1 Reply 1
Highlighted
Community Manager

Hello @efoles 

 

Thank you for the information, investigating more about it looks like that Gmail itself creates these BOM headers when it sends email replies to Gmail users who are using the Gmail "send mail as" feature.

 

In theory whitelisting will help with all deliverability issues, because the mail server should accept all emails from a whitelisted source.

 

I hope this helps.

 

Pam


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes