Contacts not loading in Firefox?

SOLVE
Highlighted
New Contributor

Currently having an issue with one of my CRM users not being able to load the Contacts or Companies page. When they tried in IE, it loaded fine. I also use the CRM in Firefox and am having no issues loading those pages. We restarted the browser, cleared the cache etc. but nothing changed it. Any suggestions?

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Highlighted
Solution
Regular Contributor

A handful of people at our agency had the same issue. If you don't already use Google Chrome, I'd recommend trying that as it seemed to fix the issue for us. 

View solution in original post

Reply
0 Upvotes
3 Replies 3
Highlighted
Resident Expert | Platinum Partner

That's odd that only certain pages won't load.

 

Are you using any Firefox Add-ons or Extensions that could be causing issues? 

 

Which version of Firefox are you using? It's working OK for me on 61.0.2.

 

When you restarted the browser and cache, did you also restart your machine? If not, that is worth a shot.

 

 




Did this post help solve your problem? If so, please mark it as a solution.

Josh Curcio

HubSpot support and inbound marketing for OEMs, contract manufacturers, and industrial suppliers.
HubSpot Platinum Partner & HubSpot Certified Trainer

Reply
0 Upvotes
Highlighted
Solution
Regular Contributor

A handful of people at our agency had the same issue. If you don't already use Google Chrome, I'd recommend trying that as it seemed to fix the issue for us. 

View solution in original post

Reply
0 Upvotes
Highlighted
New Contributor

Thanks! I don't think it was installed on that computer but we'll keep that in mind if the problem continues.

Reply
0 Upvotes