Contact form contents to Gmail inbox

SOLVE
Ru
New Contributor

Hello,

 

I'm pretty new to Hubspot and I have a question with regards the forms. I use Wordpress and I am trying to replace "Contact form 7" with the Hubspot Contact Forms (HCF).

 

My problem is that whenever someone contacts me through HCF, I don't get the email in Gmail, but just in Hubspot. Only new (non existing) customers contact me through this forms.

 

Furthermore, I am facing some problems that I hope they can serve as clues to solve my issue:

  1. When you send the form, you don't get the thank you message (my settings are to display a thank message instead of sending to a different page; see first picture)
  2. I don't get any notification despite the fact having selected both (see second picture):
    1. "Follow up Options" to "Send submission email notifications to the contact's owner"
    2. Send submission email notifications to...

Thanks in advance,

Rubén

 

contact form.pngJust after sending the form

 

opciones.pngSettings

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Highlighted
HubSpot Moderator

Hey @Ru 

 

Could you try updating the form in the top right corner of the form editor? 

 

It looks like everything is set up correctly, but the form has some unpublished changes. Whenever you make changes to a form's content or options, the form needs to be updated in order for the changes to take effect. 

 

Best,
Ana

3 Replies 3
Highlighted
HubSpot Moderator

Hey @Ru 

 

Could you try updating the form in the top right corner of the form editor? 

 

It looks like everything is set up correctly, but the form has some unpublished changes. Whenever you make changes to a form's content or options, the form needs to be updated in order for the changes to take effect. 

 

Best,
Ana

Ru
New Contributor

Morning @adimarino!,

 

Thanks for your answer. You're right, I made a small change on the form and I forgot to update the form.

It is now working perfectly.

 

Cheers,

Rubén

Reply
0 Upvotes
HubSpot Moderator

I'm so glad that did the trick! 

Reply
0 Upvotes