Can not get the contact to link with company

Highlighted
New Contributor

Hello,

 

Please could someone help me out. I have been using google sheets to store all my data but am trying to transfer it to Hubspot. 

 

The contacts and their details (last name/phone number/email) are all being transferred but the company itself is not showing up? The way I format my sheets is attached, As I just list down the names. I do not require any data - I just want when I click Bob for example - it to give me his last name/company/number/email. Hubspot .png

 

 

This is how my contacts (company) section shows. Even though all I want it to say is 'City Year' - after I choose company name while transferring the file. 

Hubspot 2.png

3 Replies 3
Regular Contributor

@Carow 

 

When you import I would suggest using a Multi-object importing from one file.  You can then delineate that the file is for contacts and companies and it should relate the two.

 

Also, Since the Contacts are already uploaded you can export the list of contacts with all details. This should give you a "unique id" on one of the columns you can then use a vLookup in Excel to add the company names to each contact and reimport with the associated id numbers for the Company. Or just order them alphabetically and they should align with your initial list.

Reply
0 Upvotes
New Contributor

I tried to use the multi-object option but when imported there are many errors that say company name 'invalid'. I do not have company domain name for any of my data lines therefore is there a way to just add the company name to a contact as a text rather than the domain? 

 

I attached what the error file says after i try importing and it failing

 

Hubspot Error.png

Reply
0 Upvotes
Regular Contributor

@Carow 

 

Are you checking the box that says "Update exiting records using "Object ID" exported from HubSpot"? You shouldn't unless you are uploading with the contact record ID.  That may be your problem from what I see with this error.

 

You can upload the Contact records by themselves with just a company name associated. If the Contacts already exist you will need to export their IDs and then reupload with the associated company name. I would suggest that you add more company info and try the multiple object upload again.