Bug report: HubSpot user not working when the additional user have permissions on team level

New Member

I try to describe the case.

I have a contact I want to share between two users working in two different teams.

Each of those users have team view and edit permissions on contacts.

The hubspot owner of the contact is one of the two users.

Creating a custom property with field type "Hubspot User" I can give to the contact a second owner like it's written here https://www.hubspot.com/product-updates/assign-objects-to-multiple-owners-using-custom-owner-propert...

Unfortunately this is perfectly working in case of users with view and edit on their contacts only but not working at all when the permission are on team level.

Reply
0 Upvotes
2 Replies 2
Highlighted
Community Manager

Hello @andreaca,

 

Wanted to confirm what is the permission of the original owner of the object? 

The permissions will respect custom owner properties.  What is the error the custom property added user is receiving? 

 

I would also recommend connecting with HubSpot Technical Support, as Support is included in your subscription and they will be able to provide real-time assistance for this matter, including hopping on a screen share if necessary. 

 

Kindly,

Pam


We are excited to announce that the Community will be launching a weekly newsletter on November 2, 2020!
Sign up today!


Highlighted
New Contributor

Hi @PamCotton , thanks for your kind reply.
The main owner of the object have a view and edit permission on team level, but the two owner works in two different team.
If I change the permission on owned only everithing works as intended but it's probably much less useful in real life.

Thanks

Andrea

Reply
0 Upvotes