CMS Development

Jsum
Conselheiro(a) de destaque

Theme modules not available in page editor

resolver

I was hired to make some adjustments to a custom built theme. It was supposed to be a 3 hour project. The first task was to clone one of the theme modules and make some layout changes to the new module. The issue is that the new module, any module I or my client creates, and most of them modules in the theme's module folder are not visibile from the page editor. There are 8 total theme modules available in the page editor out of the 30+ in the themes module folder in the design manager. And yes, they are checked to be available for templates and pages. Support can see the modules when they go to the page editor, noone else can. 

I submitted a ticket to support about this but they haven't gotten back with me. with the weekend we've been dealing with this for several days with no solution. Any ideas?

1 Solução aceita
Anton
Solução
Autoridade no assunto

Theme modules not available in page editor

resolver

Hey @Jsum

 

long time no see 😄 

 

Since I know you're working with local, check the meta.json of each module. 

There is (or should be) this line:

"is_available_for_new_content" : true

if it's set to true - you're able to use it in page builder, if set to false - you're unable to use it

 

 

best, 

Anton

Anton Bujanowski Signature

Exibir solução no post original

6 Respostas 6
Anton
Solução
Autoridade no assunto

Theme modules not available in page editor

resolver

Hey @Jsum

 

long time no see 😄 

 

Since I know you're working with local, check the meta.json of each module. 

There is (or should be) this line:

"is_available_for_new_content" : true

if it's set to true - you're able to use it in page builder, if set to false - you're unable to use it

 

 

best, 

Anton

Anton Bujanowski Signature
RJChauhan
Participante

Theme modules not available in page editor

resolver

Just make the Module visible for Templates and Page at top right (see the screenshot below)

 

RJChauhan_0-1664273599913.png

 

0 Avaliação positiva
Jsum
Conselheiro(a) de destaque

Theme modules not available in page editor

resolver

I did. I mentioned it in my post above...

0 Avaliação positiva
ChehakWadhdwa
Membro | Parceiro Diamante
Membro | Parceiro Diamante

Theme modules not available in page editor

resolver

Hey @Jsum 

 

Please once make sure whatever the module you are cloning it should be inside to that theme folder , if possible please try to change label and module icon so that you can categorize with existing one 

 

ChehakWadhdwa_0-1664263955671.png

 

Hope this helps!

If we were able to answer your query, kindly help the community by marking it as a solution.

Thanks and Regards.

0 Avaliação positiva
Jsum
Conselheiro(a) de destaque

Theme modules not available in page editor

resolver

Sorry, it doesn't. That basic trouble shooting, I'm experiencing an actual hubspot bug that no one wants to take seriously. Turning it off and back on doesn't work here...

Jnix284
Membro do Hall da Fama | Parceiro Elite
Membro do Hall da Fama | Parceiro Elite

Theme modules not available in page editor

resolver

@Jsum When you open the page editor, are you seeing only the "common" modules at the top and is the section for "theme" modules missing entirely, or are you only seeing a few of the modules within the "theme" section?

 

Also, in the page editor, are the styles of the modules collapsing and creating a nightmare to look at? Do the live pages still work? Are you getting an error that the template is missing?

 

I have encountered a very specific bug with theme related files and can help if you can confirm these details.

 

 


If my reply answered your question please mark it as a solution to make it easier for others to find.



Jennifer Nixon - Delivery Lead at Aptitude 8

connect with Jen on Linkedin

0 Avaliação positiva