CMS Development

RitaM
Member

Problem implementing Landing Page Template

SOLVE

Hi everyone!

 

I contacted Hubspot support but they weren't able to help me with this.

My development team has created a HTML +HubL page in the designer tool. It looks amazing in the preview, but after they publish it, it is nowhere to be found... We've created previous HTML pages and they show up in templates when trying to add them into the Landing Page, but not this one. Where could this be? Or how can I implement it?

 

Thank you in advance,

 

Best regards,

 

Rita

0 Upvotes
1 Accepted solution
Anton
Solution
Thought Leader

Problem implementing Landing Page Template

SOLVE

Hi @RitaM

every template requires the template informations like

<!--
templateType: page
isAvailableForNewContent: true
label: YOUR TEMPLATE NAME
-->

 at the very top. 

 

If "isAvailableForNewContent" is set to "false" then it won't show up in your template selection. 

 

Also check the label - if the dev-team cloned it from an existing templte it might have the same name

 

best,

Anton

Anton Bujanowski Signature

View solution in original post

2 Replies 2
RitaM
Member

Problem implementing Landing Page Template

SOLVE

Hi @Anton ,

 

Thank you so much for your help! This worked perfectly!

 

Best regards,

 

Rita

0 Upvotes
Anton
Solution
Thought Leader

Problem implementing Landing Page Template

SOLVE

Hi @RitaM

every template requires the template informations like

<!--
templateType: page
isAvailableForNewContent: true
label: YOUR TEMPLATE NAME
-->

 at the very top. 

 

If "isAvailableForNewContent" is set to "false" then it won't show up in your template selection. 

 

Also check the label - if the dev-team cloned it from an existing templte it might have the same name

 

best,

Anton

Anton Bujanowski Signature