NoIndex being inserted into page

SOLVE
Regular Advisor | Platinum Partner

hello all,

I have an html template that is used for dynamic pages. For some reason, there is a noindex, nofollow meta tag in my head.   How can i remove? 

here is an example link

here is the head of the template

<head>
    <meta charset="utf-8">
    <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">
    <meta name="author" content="{{ meta_author }}">
    <meta name="description" content="{{ page_meta.meta_description }}">
    <meta name="generator" content="HubSpot">
    <title>{{ dynamic_page_hubdb_row.hs_name }}</title>
    {% if site_settings.favicon_src %}<link rel="shortcut icon" href="{{ site_settings.favicon_src }}" />{% endif %}
    
{{ required_head_tags }}
    
    {{ include_attached_css( [{"id":5936059258,"type":"cos_extension_resource"}]) }}
    {{ user_head_overrides }}
  <link rel="stylesheet" href="/hs-fs/css/3955296/hub_generated/template_assets/1535396734971/combined-css-7b20fce45872d8a6a02e85a8ebb33293.css">

</head>
dennis
Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Highlighted
Advisor

Hi @dennis_e,

there are a few possible "positions" where you can a noindex,nofollow in HubSpot.

It could also come from the 

 

1. in the portal settings

2. in the page settings

3. in the template settings in the design manager(works only with templates which are build with the design manager and aren't HTML;since your template is a HTML one, this doesn't work but I leave it here for completeness)

 

there are a few other possible positions where a noindex,nofollow could be, but since nobody should use them - i won't notice them Smiley Happy (also this works only with the HubSpot builder not HTML templates)

 

here you'll find them

 

1. portal settings:

- click on the cog-icon in the top-right corner of your portal

- navigate to website-pages

- if it's here then you'll find it inside the "Website-Header-HTML" option

 

2. page settings:

- go to the page editor(Marketing->Website/Landingpage)

- open your page

- go to the settings(middle tab found on top)

- open the advanced/expanded options

- if it's here you'll find it inside the "additional code-snippets" inside the "head HTML" part

 

3. design manager(template builder)

- go to the design manager(marketing->files and templates)

- open your template

- make sure that nothing is selected and you see the head and body options in the right sidebar

- if it's here then it will be in the "additional <head> markup" field

  

 

hope this helps

 

regards,

Anton

 

Did my post help answer your query? Help the Community by marking it as a solution







check Did my post help answer your query? Help the Community by marking it as a solution
3 Replies 3
Top Advisor | Gold Partner

@dennis_e - I'm sure you have checked the usual spots, here's one that is easily overlooked

click the gear icon in the top right

last menu item on the left is websites

choose blog

and check that it's not in the header code there

robot.png

Reply
0 Upvotes
Highlighted
Advisor

Hi @dennis_e,

there are a few possible "positions" where you can a noindex,nofollow in HubSpot.

It could also come from the 

 

1. in the portal settings

2. in the page settings

3. in the template settings in the design manager(works only with templates which are build with the design manager and aren't HTML;since your template is a HTML one, this doesn't work but I leave it here for completeness)

 

there are a few other possible positions where a noindex,nofollow could be, but since nobody should use them - i won't notice them Smiley Happy (also this works only with the HubSpot builder not HTML templates)

 

here you'll find them

 

1. portal settings:

- click on the cog-icon in the top-right corner of your portal

- navigate to website-pages

- if it's here then you'll find it inside the "Website-Header-HTML" option

 

2. page settings:

- go to the page editor(Marketing->Website/Landingpage)

- open your page

- go to the settings(middle tab found on top)

- open the advanced/expanded options

- if it's here you'll find it inside the "additional code-snippets" inside the "head HTML" part

 

3. design manager(template builder)

- go to the design manager(marketing->files and templates)

- open your template

- make sure that nothing is selected and you see the head and body options in the right sidebar

- if it's here then it will be in the "additional <head> markup" field

  

 

hope this helps

 

regards,

Anton

 

Did my post help answer your query? Help the Community by marking it as a solution







check Did my post help answer your query? Help the Community by marking it as a solution
Regular Advisor | Platinum Partner

@Anton, @tjoyce --  was on the page.  Still getting used to dynamic pages.  Slipped my mind that i had to publish a generic page for all the dynamic pages to reference. 

Robot Frustrated

dennis