LeadFlow Errors

Highlighted
New Contributor

Hello community, I've facing this issue on my nextjs app and it's causing my app to break when this console error pops up. Any help available?


leadflows.js:1 Uncaught TypeError: t.report is not a function
at Object.getPortalId (leadflows.js:1)
at Object.setUpErrorReporting (leadflows.js:11)
at Object.setUp (leadflows.js:11)
at a (leadflows.js:11)
at leadflows.js:11
at leadflows.js:11

Reply
0 Upvotes
3 Replies 3
Highlighted
Community Manager

Hey @Malvin_j 

Sorry you are having this issue.  Do you have any more details that you can provide? 

@stefen, @malcolm1  have you seen this happen before?

Thanks,

Dennis


We are excited to announce that the Community will be launching a weekly newsletter on November 2, 2020!
Sign up today!
Reply
0 Upvotes
Highlighted
Regular Advisor | Partner

@dennisedson @Malvin_j that's a new one for me. But, I also don't have much nextjs experience. I wonder if it's trying to codesplit the 3rd party hubspot script?

Stefen Phelps, Community Champion, Kelp Web Developer
Reply
0 Upvotes
Highlighted
New Contributor

Yes! I do get these errors after I successfully subscribe as a lead.

At first, I suspected the inclusion of reCAPTCHA on the contact form so I took it off but there was no luck. 
Currently I'm including the tracking code as a header script tag in nextjs and maybe that could also be the issue but I'm not too sure as it works very fine until I ( or any user) subscribes via the contact form then the issues starts occuring.

 

In conclusion, I would like to know if there's an alternative solution of implementing hubspot integration in a webapp apart from using the script tag. Thank you.

 

Reply
0 Upvotes