HubDB goes empty - cache ?

Highlighted
New Contributor

Ok. I have created a simple module that gets a list of items from a specific HubDB table.

 

I haven't touched it for a week, and it used to work. But now my module returns as if the table is empty. 

 

It is NOT empty in HubDB.

 

A sample of my code:

{% set typesTable = hubdb_table_rows(2029842) %}

 

{{ typesTable|length }} returns 0.

 

I tried to run the module in "Preview" mode and the data gets populated. But if i run the live production page, it returns empty.

 

My table is published and i even tried unpublishing, and publishing it.

 

It have happened before to a colleague of mine. That is a big problem, if your HubDB data suddenly disappears on your production page and you can't do anything to make it come back? It seems like there is some server-side HubDB cache that is working badly ?

Reply
0 Upvotes
2 Replies 2
Advisor

Hey @Krisp 

 

Long shot but in your page have you specified which table you would like accessible to the page?

 

Screeenshot - 2019-11-19 at 3.35.23 PM.png

 

Website > Edit >settings > Advanced Options > HubDB Dropdown

New Contributor

Hi again.

 

That is only for dynamic pages, this is not a dynamic page. I have a direct reference to a specific table.

Reply
0 Upvotes